izmir escort

antalya escort

izmir escort

porno

porno izle

bursa escort

escort

mobil porno

havalandirma sistemleri

antalya escort

beylikdüzü escort

takipçi satın alma

instagram beğeni hilesi

instagram takipçi hilesi

saha betonu

izmir escort

eskisehir escort bayan

porno yabanci

takipçi al

beğeni al

takipçi satın al

beğeni satın al

takipçi satın al

takipçi satın al

izmir eskort

sex hikaye

takipçi satın al

takipçi satın al

ifşa türk

adana bayan escort

ümraniye escort

mudanya escort

şaşmaz escort

tunceli escort

bayan escort

instagram satın al takipçi

instagram satın alma takipçi

Smm panel dünyanın en ucuz sistemi

Display gone wacko
500 Madness
   
Results 1 to 10 of 10

Thread: Display gone wacko

  1. #1
    Junior Member
    Join Date
    Sep 2018
    Posts
    18
    Thanks
    0
    Thanked 5 Times in 3 Posts

    Display gone wacko

    My 2015 500e has learned a new trick! The temp display shows either 175F or 185F, and then it intermittently flashes the ice warning and sounds the buzzer. And it goes on and on and on... Sometimes it stops for a while, but the temp display stays at 185.

    The temp display has never been accurate since I got the car in 2018. Usually off by 10 or more degrees.

    Last month my 12v battery died, so I replaced it with the proper battery. This issue showed up a couple weeks after that.

    Where is the sensor for the temp display?

    Video at http://www.ereserve.com/500e/500e.mp4

  2. #2
    Senior Member ElectricTireShredder's Avatar
    Join Date
    Feb 2020
    Location
    Los Angeles
    Posts
    356
    Thanks
    183
    Thanked 69 Times in 58 Posts
    Apparently it's inside the passenger door's mirror.
    2013 500e has been my only car since 2015.

  3. #3
    Junior Member
    Join Date
    Sep 2018
    Posts
    18
    Thanks
    0
    Thanked 5 Times in 3 Posts
    TY - Suppose I'll go have a look. Wouldn't it be great if it was something simple...

  4. #4
    Junior Member
    Join Date
    Sep 2018
    Posts
    18
    Thanks
    0
    Thanked 5 Times in 3 Posts
    I pulled the door panel, and poked around a little. All looks intact, but since I don't have any replacement parts, I didn't go in too deep to avoid damaging the water shield. After searching online a while, I'm unable to locate a replacement temperature sensor. I've no idea yet if that's the issue, or even the cost of the part. Don't really like shotgunning replacement parts, but I need to start somewhere I guess... I would imagine the temp sensor is not specific to the 500e, but who knows? Worst case I'll pull the mirror and see if I can identify the temp sensor. Then I can perhaps test it once the device parameters are known... Really hoping it's just the sensor and/or connectors/wiring.

  5. #5
    Senior Member ElectricTireShredder's Avatar
    Join Date
    Feb 2020
    Location
    Los Angeles
    Posts
    356
    Thanks
    183
    Thanked 69 Times in 58 Posts
    Assuming you have left the error-causing humidity sensor unplugged, maybe get a WIRELESS* obd reader & check for error codes.


    * Problems can occur in a 500e if you plug in an OBD reader wired to its own screen. I've been using a Konnwei KW902, which reportedly will correct the rare-but-debilitating contactor glitch, but it truncates the data logs.

    I haven't had any real need for those logs, or for the "yellow adapter" that the AlfaOBD app requires for some module readings. However, if an extra $100 isn't that bad for you**, I'd recommend the OBDLink MX+, as recommended by AlfaOBD themselves.



    ** Or if you consider the fact that you may eventually need the logs, or maybe the yellow adapter (which might not work with the KW), in which case it would actually cost less long term to just buy the OBDLink in the first place.
    Last edited by ElectricTireShredder; 09-10-2022 at 07:13 PM.
    2013 500e has been my only car since 2015.

  6. #6
    Moderato map's Avatar
    Join Date
    Dec 2018
    Location
    Eugene
    Posts
    3,385
    Thanks
    1,214
    Thanked 1,198 Times in 989 Posts
    Usually when the temp varies like that, the thermistor has failed. The mirror can be replaced or, if you are handy with a soldering iron, the thermistor can be replaced. I'd probably go with the +/- thermistor for under $1 vs $170 for the mirror. With care you might not even have to remove the mirror from your car.

    http://www.fiat500usaforum.com/showt...erature-sensor

  7. The Following User Says Thank You to map For This Useful Post:

    ElectricTireShredder (09-11-2022)

  8. #7
    Junior Member
    Join Date
    Sep 2018
    Posts
    18
    Thanks
    0
    Thanked 5 Times in 3 Posts
    I pulled the passenger mirror off and replaced the sensor. Used an air conditioner temperature sensor since I happened to have it handy, and the specs were similar. Error fixed and the darn thing is actually accurate for the 1st time ever.

  9. The Following 3 Users Say Thank You to 7chord For This Useful Post:

    5port (09-19-2022), bryanintowson (09-20-2022), ElectricTireShredder (09-20-2022)

  10. #8
    Senior Member Fabio13's Avatar
    Join Date
    Jul 2014
    Location
    Southwest
    Posts
    982
    Thanks
    581
    Thanked 401 Times in 290 Posts
    Quote Originally Posted by 7chord View Post
    I pulled the passenger mirror off and replaced the sensor. Used an air conditioner temperature sensor since I happened to have it handy, and the specs were similar. Error fixed and the darn thing is actually accurate for the 1st time ever.
    Part number, specs? So others can be helped in the future.
    2013 Fiat 500 Sport AT, Xpel Ultimate Clear Bra, 3M Crystalline Window Tint, Black top stripes, Black "500" (wide) side stripes. Fiat "500" Stainless door sills by Mopar. BlueTooth music streaming. OBDII BlueTooth Torque gauges streaming to smart phone. Michelin Pilot Sport A/S 3 Plus tires, STS rear sway bar, Euro+Drive NA 500 Tune, BMC reusable air filter and Spare Tyre with cover.

    Blast to drive! 25 years newer than last car!

  11. The Following User Says Thank You to Fabio13 For This Useful Post:

    ElectricTireShredder (09-21-2022)

  12. #9
    Moderato map's Avatar
    Join Date
    Dec 2018
    Location
    Eugene
    Posts
    3,385
    Thanks
    1,214
    Thanked 1,198 Times in 989 Posts

  13. #10
    smark's Avatar
    Join Date
    Apr 2014
    Posts
    4,453
    Thanks
    1,641
    Thanked 1,649 Times in 1,253 Posts
    Before you start replacing a bunch a parts. You might just have corrupted software,
    giving you all those crazy temp readings.

Similar Threads

  1. Display in metric?
    By LA2019 in forum Fiat 500X
    Replies: 5
    Last Post: 01-19-2020, 11:02 PM
  2. 500 Pop oil pressure sensor wacko
    By rickley in forum Questions about the Fiat 500
    Replies: 6
    Last Post: 09-06-2016, 10:59 AM
  3. A new display I had not seen before
    By Greg Elmassian in forum Fiat 500e Images
    Replies: 8
    Last Post: 01-03-2015, 04:57 PM
  4. Display Trip B
    By Trystane in forum Fiat 500L
    Replies: 16
    Last Post: 09-29-2013, 01:48 PM
  5. Display
    By 4Play in forum Fiat 500 General Discussion
    Replies: 11
    Last Post: 10-23-2012, 01:39 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •