izmir escort

antalya escort

izmir escort

porno

porno izle

bursa escort

escort

mobil porno

havalandirma sistemleri

antalya escort

takipçi satın alma

instagram beğeni hilesi

instagram takipçi hilesi

saha betonu

izmir escort

eskisehir escort bayan

porno yabanci

takipçi al

beğeni al

takipçi satın al

beğeni satın al

takipçi satın al

takipçi satın al

izmir eskort

sex hikaye

takipçi satın al

takipçi satın al

ifşa türk

adana bayan escort

ümraniye escort

mudanya escort

şaşmaz escort

tunceli escort

bayan escort

instagram satın al takipçi

instagram satın alma takipçi

Smm panel dünyanın en ucuz sistemi

Can't figure out this boost issue, and it's killing me.
500 Madness
   
Results 1 to 6 of 6

Thread: Can't figure out this boost issue, and it's killing me.

  1. #1
    Member
    Join Date
    Jun 2020
    Location
    Pennsylvania
    Posts
    67
    Thanks
    9
    Thanked 13 Times in 9 Posts

    Can't figure out this boost issue, and it's killing me.

    The link to the video:



    Okay, so...

    Couple of weeks ago I finally found my boost leak. There was a hole in one of my stock intercoolers. Fine.

    Bought a front mount from Madness. Installed it, all is good.

    Take it out for the first drive and the boost fluctuates wildly at WOT. It'll go from 21psi (mechanical guage) to 15 to 20 to 17) over and over. My car has a high flow downpipe so you can hear the wastegate being opened and closed while it does.

    Annoying, but I figure it's the wastegate solenoid because the car is a 2013 with almost 100k miles. So I order a new one, replace it, and there is a small tear in one of the boots on my old one, so I figure that was the problem. Drive it for a day and it felt mostly fine, though it did overboost a few times by a couple of psi, it didn't go crazy pulling it back. It would spike 20 or so, pull it back to 18, and hold.

    Yay!... Or not...

    After another drive, I noticed it do the boost fluctuation just once. So I reset the ECU by unhooking the battery for hours. Put it back together and it was just as before, mostly fine with some spikes to 20, but nothing crazy, again.

    Yay! Again! Or not... Again!

    Tonight I took it out onto the interstate (in Mexico) to really run through the gears. The video clip is from tonight.

    The first clip is right after I pulled onto the highway, the second is maybe a minute later.

    Now it's intermittent. Some pulls it fluctuates, some pulls it holds right at 18, some pulls it over boosted then pulled it back in. Tonight is also when I noticed that the factory boost gauge, at times, is showing something like 22psi. My mechanical gauge isn't agreeing.

    So I'm at a loss. I need help. I've dumped so much money into this car and it's killing me. I just want it to be right.

    The car is a 2013, manual, Multiair with 99k ish miles.

    It has a 500Madness front mount, ATP high flow downpipe, Sila short ram intake, and Turbosmart Wastegate actuator, adjusted to 2mm preload. I did the diy version of the EC boost leak fix, and other than that the car is stock. I don't believe it was tuned as the ECU appears stock, and the previous owner seemed cheap/lazy.

    The only thing left really is either the TS wastegate is faulty, or the turbo is faulty. I can't afford a turbo right now, or an actuator for that matter, but if we all agree it's the actuator maybe I can rebuild it?

    I don't know.

    Help.
    Last edited by Fiat500USA; 06-21-2022 at 11:25 PM. Reason: embedded video for easier viewing
    2013 Abarth in Rosso Red.


    ATP High Flow Downpipe.
    Short Ram Intake
    Turbosmart WG

  2. #2
    Lifetime Member Lifetime Member
    Join Date
    Jul 2014
    Posts
    1,285
    Thanks
    566
    Thanked 316 Times in 251 Posts
    I recommend picking up an OBDLink MX+ and datalogging spark knock reduction. I'll be posting a tutorial as soon as possible.


    2015 Fiat 500 Abarth
    Power:Tork 3" Intake, Forge BOV, ATM FMIC, Tork S1/S2/Meth Tune, Tork CC Catless DP, Boost Leak Fix, Turbosmart WGA, Ragazzon Twin Muffler Cat Back
    Handling: H&R 5mm spacers, El Gato Front Braces, Tork Collars, DoverLabs Coilovers, CPR lower brace
    Misc: Schrothe QuickFit Harness, OBDLink MX+, Race Tires: 205/45/16 Falken RT660, Street/Drag: 205/45/16 Conti ECS, HAWK HPS5.0
    DSP/D-class (local club classing)
    #notscare

  3. #3
    Member
    Join Date
    Jun 2020
    Location
    Pennsylvania
    Posts
    67
    Thanks
    9
    Thanked 13 Times in 9 Posts
    I popped the cap off my wastegate to check what spring was in there. It doesn't quite match the options TS lists, but it IS pink on the bottom ring, which is 7psi according to them. 20220622_120621.jpg
    2013 Abarth in Rosso Red.


    ATP High Flow Downpipe.
    Short Ram Intake
    Turbosmart WG

  4. #4
    Member
    Join Date
    Jun 2020
    Location
    Pennsylvania
    Posts
    67
    Thanks
    9
    Thanked 13 Times in 9 Posts
    "I recommend picking up an OBDLink MX+ and datalogging spark knock reduction. I'll be posting a tutorial as soon as possible"

    I'll have to see if the Torque app can monitor that.
    2013 Abarth in Rosso Red.


    ATP High Flow Downpipe.
    Short Ram Intake
    Turbosmart WG

  5. #5
    Lifetime Member Lifetime Member
    Join Date
    Jul 2014
    Posts
    1,285
    Thanks
    566
    Thanked 316 Times in 251 Posts
    I took a look at the video because it's blocked at my work but I don't see anything "boost related" to be worried about. The ECU's PID loops are controlling boost the way it is intended though you may not hit your targets, the boost system appears to be working just fine.

    I have no idea on Torque anymore. I've moved on to much better datalogging options that can log spark knock and do so with sufficient polling speeds. If you can log spark knock timing reductions with Torque, do a 4th gear pull from 2000-6000RPM. If you can't do 4th gear, try 2nd or 3rd to start.


    2015 Fiat 500 Abarth
    Power:Tork 3" Intake, Forge BOV, ATM FMIC, Tork S1/S2/Meth Tune, Tork CC Catless DP, Boost Leak Fix, Turbosmart WGA, Ragazzon Twin Muffler Cat Back
    Handling: H&R 5mm spacers, El Gato Front Braces, Tork Collars, DoverLabs Coilovers, CPR lower brace
    Misc: Schrothe QuickFit Harness, OBDLink MX+, Race Tires: 205/45/16 Falken RT660, Street/Drag: 205/45/16 Conti ECS, HAWK HPS5.0
    DSP/D-class (local club classing)
    #notscare

  6. #6
    Member
    Join Date
    Jun 2020
    Location
    Pennsylvania
    Posts
    67
    Thanks
    9
    Thanked 13 Times in 9 Posts
    Quote Originally Posted by doverosx View Post
    I took a look at the video because it's blocked at my work but I don't see anything "boost related" to be worried about. The ECU's PID loops are controlling boost the way it is intended though you may not hit your targets, the boost system appears to be working just fine.

    I have no idea on Torque anymore. I've moved on to much better datalogging options that can log spark knock and do so with sufficient polling speeds. If you can log spark knock timing reductions with Torque, do a 4th gear pull from 2000-6000RPM. If you can't do 4th gear, try 2nd or 3rd to start.
    The boost is fluctuating between 20 and 15 psi intermittently. You can hear the wastegate opening and closing repeatedly instead of smoothly opening and holding 18psi like it is meant to.

    I have an OEM actuator on the way to test that. So I should know by Monday or Tuesday if that's the issue.
    2013 Abarth in Rosso Red.


    ATP High Flow Downpipe.
    Short Ram Intake
    Turbosmart WG

Similar Threads

  1. Boost Issue after upgrades
    By Seanzie in forum Fiat 500 ABARTH Issues and Concerns
    Replies: 7
    Last Post: 10-14-2019, 02:09 PM
  2. Potential boost leak/air filter issue
    By Saled in forum Fiat 500 Issues and concerns
    Replies: 8
    Last Post: 01-25-2019, 10:27 AM
  3. Boost Issue?
    By abarthski in forum Fiat 500 ABARTH Issues and Concerns
    Replies: 1
    Last Post: 03-02-2018, 11:15 AM
  4. MM P2262 Boost Issue
    By ivmill in forum Fiat 500 ABARTH Issues and Concerns
    Replies: 3
    Last Post: 09-25-2013, 06:54 PM
  5. My Hobbies are killing me
    By Berliner in forum Off Topic
    Replies: 0
    Last Post: 12-07-2012, 12:16 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •