bahis siteleri Betboo yeni adresi izmir escort antalya escort izmir escort porno porno izle bursa escort escort mobil porno havalandirma sistemleri takipçi satın alma instagram beğeni hilesi instagram takipçi hilesi saha betonu izmir escort eskişehir escort bayan Air cleaner box broken during air filter change. Common? - Page 2
500 Madness
   
Page 2 of 2 FirstFirst 1 2
Results 11 to 20 of 20

Thread: Air cleaner box broken during air filter change. Common?

  1. #11
    smark's Avatar
    Join Date
    Apr 2014
    Posts
    3,030
    Thanks
    990
    Thanked 1,048 Times in 797 Posts
    Quote Originally Posted by Shumifan View Post
    The dealer said there is nothing wrong with the part. As I said in another post, this looks like a very weak area that will easily brake. I am trying to see if anybody has have this issue.
    So the dealer said the part, is ok? Not broken. Thats good. Saved you 42 buck, for a replacement one.


  2. #12
    AWD enthusiast Lifetime Member 5port's Avatar
    Join Date
    May 2012
    Location
    New York
    Posts
    665
    Thanks
    461
    Thanked 298 Times in 224 Posts
    Quote Originally Posted by Shumifan View Post
    i should have mentioned that my car has a 1.4 liter engine. The air box looks different than your picture. I can't find the correct part in the moparonlilneparts...
    Yes that would help. We have already had someone with the 1.4L had this happen. I forget who.
    2016 Fiat 500X Easy

  3. #13
    Junior Member
    Join Date
    Sep 2020
    Location
    New Mexico
    Posts
    10
    Thanks
    3
    Thanked 1 Time in 1 Post
    To all who responded to my original post, "Thanks".
    This is a picture of the small hose entering the air box. I glued as well as I could and placed a small wire to support it. The break is in the area held by the wire. This is shown in the second pic. The tip of the arrow points exactly to where I glued the broken piece. Hope this is clear enough. Any advise will be welcomed.
    Now that I see the picture, the broken part is not the air cleaner box per se but the plastic angle connector that receives the return line from the engine.
    Thanks.
    Attachment 37982Attachment 37983

  4. #14
    Junior Member
    Join Date
    Sep 2020
    Location
    New Mexico
    Posts
    10
    Thanks
    3
    Thanked 1 Time in 1 Post
    Sorry I did not express myself well> The dealer said that there is nothing wrong with the design/manufacturing of the piece. They could see it was broken but did not want to cover it under warranty.

  5. The Following User Says Thank You to Shumifan For This Useful Post:

    smark (09-20-2020)

  6. #15
    smark's Avatar
    Join Date
    Apr 2014
    Posts
    3,030
    Thanks
    990
    Thanked 1,048 Times in 797 Posts
    Quote Originally Posted by Shumifan View Post
    To all who responded to my original post, "Thanks".
    This is a picture of the small hose entering the air box. I glued as well as I could and placed a small wire to support it. The break is in the area held by the wire. This is shown in the second pic. The tip of the arrow points exactly to where I glued the broken piece. Hope this is clear enough. Any advise will be welcomed.
    Now that I see the picture, the broken part is not the air cleaner box per se but the plastic angle connector that receives the return line from the engine.
    Thanks.
    Attachment 37982Attachment 37983
    The attachment not there.

  7. #16
    Junior Member
    Join Date
    Sep 2020
    Location
    New Mexico
    Posts
    10
    Thanks
    3
    Thanked 1 Time in 1 Post
    The attachments are in the body on my post above. # 37982 and 37983. If you click on them the picture opens...

  8. #17
    smark's Avatar
    Join Date
    Apr 2014
    Posts
    3,030
    Thanks
    990
    Thanked 1,048 Times in 797 Posts
    Quote Originally Posted by Shumifan View Post
    The attachments are in the body on my post above. # 37982 and 37983. If you click on them the picture opens...
    E86025D9-F0D2-4787-BAB4-A6CB3D3A73E0.jpg

  9. #18
    Amministratore Fiat500USA's Avatar
    Join Date
    Feb 2011
    Location
    New York
    Posts
    13,207
    Thanks
    7,627
    Thanked 6,812 Times in 4,047 Posts
    Quote Originally Posted by smark View Post
    Unfortunately the above attachments don't display and aren't in the system. Could be the file size or some other issue with the image. If you make a post and the image doesn't display and there is the word "attachment" plus a number, you will need to edit your post. Any attachments displayed in a post with the word, Attachment, followed by a number, have not been added to a post. It is a quirk of the vBulletin system. I apologize for the hassle.
    Enjoy the Forum, or has it helped? Please Whitelist us on your Ad Blocker. Thx!

    #modifiedabarth modifiedabarths.com

    abarth500forum.com fiat124spiderforum.com fiat500lusaforum.com fiat500xforum.com

  10. #19
    Junior Member
    Join Date
    Sep 2020
    Location
    New Mexico
    Posts
    10
    Thanks
    3
    Thanked 1 Time in 1 Post
    Quote Originally Posted by Fiat500USA View Post
    Unfortunately the above attachments don't display and aren't in the system. Could be the file size or some other issue with the image. If you make a post and the image doesn't display and there is the word "attachment" plus a number, you will need to edit your post. Any attachments displayed in a post with the word, Attachment, followed by a number, have not been added to a post. It is a quirk of the vBulletin system. I apologize for the hassle.
    I think I understand. However, the pics were shown on my end when I posted them> Also when I went back into the thread and clicked on the attachment link they did open and display the picture. Perhaps that happened in my computer but not in the post. I will try again to post one picture at the time.

  11. #20
    Senior Member fast_dave's Avatar
    Join Date
    Apr 2015
    Location
    SF Bay Area - PRK
    Posts
    199
    Thanks
    138
    Thanked 104 Times in 65 Posts
    @Shumifan

    Stop spinning your wheels with the dealer

    Your time is better spent searching on Ebay for a 1.4 500X wreck (and message them and if they will sell you the airbox) OR search on Ebay for the actual part - used.

    When searching wrecks, to ensure they have a 1.4 (as opposed to the 2.4) utilize the link below.

    REPLACE the 17 Digit VIN Number on the link with the 17 Digit VIN Number off the wreck you're investigating, then hit "enter" .

    Hopefully the window sticker of the wreck you're looking at will pop up.

    You can experiment by entering your X's VIN Number in the end of the URL "link"

    Engine & Transmission info is listed on the Top/Left of the window sticker.

    Link to Fontographer 5.0: https://www.chrysler.com/hostd/windo...CFYBT7GP401499

    Hope that helps and report back!
    Last edited by fast_dave; 09-22-2020 at 02:30 PM.
    2012 Sport 5 speed Manual Trans, SPC Adjustable Front Camber Bolts, CorsaStrada Lower Front Chassis Brace, ST Rear Sway Bar, 205/45/16 Bridgestone Potenza RE760 Sport Tires

Page 2 of 2 FirstFirst 1 2

Similar Threads

  1. Replies: 0
    Last Post: 08-10-2020, 02:03 PM
  2. Broken rocker panels..common?
    By carfreak09 in forum Fiat 500X Issues and Concerns
    Replies: 3
    Last Post: 12-12-2017, 10:31 PM
  3. First oil change = broken hood release cable!
    By bglz42 in forum Fiat 500 ABARTH Issues and Concerns
    Replies: 5
    Last Post: 01-16-2015, 01:06 AM
  4. Change oil/filter?
    By modular in forum Fiat 500 ABARTH General Discussion
    Replies: 12
    Last Post: 04-05-2014, 02:20 PM
  5. Air filter change out
    By Or500L in forum Fiat 500L Issues and Concerns
    Replies: 3
    Last Post: 10-21-2013, 06:00 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •