mobil onay değerli oranlar izmir escort antalya escort izmir escort porno porno izle bursa escort escort porno havalandirma sistemleri izmir escort bursa escort izmir escort izmir escort istanbul escort
Rough Acceleration and CEL
500 Madness
   
 

KONI Shock Value Sale

 
Results 1 to 2 of 2

Thread: Rough Acceleration and CEL

  1. #1
    Junior Member
    Join Date
    May 2019
    Posts
    8
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Rough Acceleration and CEL

    Login to stop seeing this advertisement

    IMG_5400.jpg

    Shortly after I bought the car back in August, I've been trying to diagnose this one issue. The car under 70-90% throttle will start strutter/misfiring in the upper RPM range. It will continue to do so until I let off the gas and reapply or it shift gears. I thought it could be the spark plugs or coil packs so I upgraded those to properly gapped ones and the 4C coils. I noticed My valve cover had a leak and there was some oil in one of the spark plugs so I replaced the entire valve cover and gaskets as well. Also replaced both O2 sensors when I installed the downpipe. So far none of that has fixed it, except the spark plug/coil swap seemed to get better for a week or so. The car is also running the OFT stage 1 file, but it does the same on the stock map.
    Until this week, the car never threw codes when running rough, and now that I have pulled the codes I reads P106A, P1066, P106C and P1068. I think the codes and this issue are related. The code says it has to do with oil supply, but oil levels are fine and I have not found any obvious leaks. And the last oil change was fairly recent. My last idea is to just replace the PCM on the car, but I'm not sure if I need to go to a dealer to get it programed and whatnot.
    If anyone knows of a good Fiat shop in the Bay Area I might just take it in at this point, but I do not trust dealerships.

    Mods:
    EC Intake
    4C coils
    OFT Stage 1 tune
    APT Downpipe
    Oil Catch Can

  2. #2
    Junior Member
    Join Date
    May 2019
    Posts
    8
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Login to stop seeing this advertisement

    Looks like the intake system is full of oil and i have none in the pan. Need to isolate the source of the issue still.

Similar Threads

  1. wobble low rpm acceleration only
    By SethChaucer in forum Fiat 500 ABARTH Issues and Concerns
    Replies: 5
    Last Post: 01-12-2018, 02:13 PM
  2. I want more acceleration and traction, please help.
    By gundam2000 in forum Fiat 500 ABARTH Engine and Drivetrain Tuning
    Replies: 4
    Last Post: 09-15-2016, 06:04 PM
  3. A/C Slowing Down Acceleration?
    By n3v3rfollow in forum Fiat 500 ABARTH General Discussion
    Replies: 27
    Last Post: 07-24-2015, 05:31 PM
  4. 500L acceleration
    By tyturri in forum Fiat 500L Issues and Concerns
    Replies: 2
    Last Post: 09-23-2014, 05:59 PM
  5. 500 Acceleration
    By RacerRon in forum Fiat 500 General Discussion
    Replies: 21
    Last Post: 02-12-2011, 12:31 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •