404

Not Found

The resource requested could not be found on this server!


Proudly powered by LiteSpeed Web Server

Please be advised that LiteSpeed Technologies Inc. is not a web hosting company and, as such, has no control over content found on this site.

izmir escort antalya escort izmir escort porno porno izle bursa escort escort mobil porno havalandirma sistemleri takipçi satın alma instagram beğeni hilesi instagram takipçi hilesi saha betonu izmir escort eskişehir escort bayan
2014 500L Thermostat housing radiator hose clamp leaking - general questions
500 Madness
   
Results 1 to 2 of 2

Thread: 2014 500L Thermostat housing radiator hose clamp leaking - general questions

  1. #1
    Junior Member
    Join Date
    Aug 2019
    Location
    Las Vegas NV
    Posts
    7
    Thanks
    0
    Thanked 0 Times in 0 Posts

    2014 500L Thermostat housing radiator hose clamp leaking - general questions

    Login to stop seeing this advertisement

    Has anyone here ever experienced a leaking upper radiator hose clamp where it connects to the thermostat housing, deeply buried below the vacuum pump, above the transmission? I discovered what appeared to be rust dripping from it onto my transmission. I felt underneath as far as I could reach and thought there was a metal pipe that had rotted through. I thought that was really strange, so I took a scope camera and looked around and discovered a very rusty looking hose clamp. I cannot find the screw to tighten or remove this clamp. Is it one of the factory crimped clamps? That might explain things. Anyway, I also discovered that this brown crud wasn't rust but instead the dried up anti-freeze. Just wondering if anyone else had experienced something similar. It's weird that a factory clamp would fail like this.

    Thanks in advance for any suggestions!
    Eric

  2. #2
    Junior Member
    Join Date
    May 2020
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Login to stop seeing this advertisement

    How did you fix the leak? Think I'm having the same issue on a 2013 500 Pop

Similar Threads

  1. Radiator hose diameter, please?
    By streetsurfer in forum Fiat 500 DIY
    Replies: 4
    Last Post: 07-11-2018, 04:12 PM
  2. Coolant Hose Clamp Issues
    By Fiatfan522 in forum Fiat 500 ABARTH Issues and Concerns
    Replies: 8
    Last Post: 02-27-2018, 11:52 PM
  3. Inside diameter of upper radiator hose? Oil pressure sensor location
    By btimothy4 in forum Fiat 500 ABARTH Engine and Drivetrain Tuning
    Replies: 2
    Last Post: 10-11-2014, 12:40 AM
  4. Replies: 5
    Last Post: 10-07-2014, 01:31 AM
  5. General performance questions from a new owner
    By Fiatfan522 in forum Fiat 500 ABARTH Engine and Drivetrain Tuning
    Replies: 4
    Last Post: 07-21-2014, 02:41 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •