iddaa tahminleri banko tahmin gaziantep escort ankara escort ankara escort izmir escort antalya escort izmir escort porno porno izle bursa escort escort porno havalandirma sistemleri izmir escort bursa escort izmir escort izmir escort istanbul escort
2014 500L power loss with no check engine light
500 Madness
   
Results 1 to 5 of 5

Thread: 2014 500L power loss with no check engine light

  1. #1
    Junior Member
    Join Date
    Jun 2019
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    2014 500L power loss with no check engine light

    Sorry posted this already but in the wrong spot.
    Hey guys new here I searched around but didnt see a similar post. I have a 2014 Fiat 500L with about 47k on it. It is a six speed manual trekking. I have recently been having random issues with power loss. When driving after a period of time my cruise control will turn off and it is like I have no assistance from the turbo. I have changed the plugs and upgraded my coil packs to the Alfa Romeo packs. It worked fine for a week and now I am having the issue again.

    Anyone else having this issue. I have seen some people report this problem but apparently no fix from Fiat as there is no check engine light.

    Any help is very much appreciated

  2. #2
    Junior Member
    Join Date
    Jun 2019
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Also 3 of my spark plug tubes have this white dust or corrosion I am thinking it may be time for new spark plug tubes and valve cover gasket.

    20190608_082856.jpg
    20190608_082900.jpg
    Last edited by zstamp19; 06-08-2019 at 09:19 AM.

  3. #3
    Fiat Top Care Specialist FiatCares's Avatar
    Join Date
    Mar 2012
    Location
    Detroit, Michigan
    Posts
    1,266
    Thanks
    17
    Thanked 418 Times in 283 Posts
    Quote Originally Posted by zstamp19 View Post
    Sorry posted this already but in the wrong spot.
    Hey guys new here I searched around but didnt see a similar post. I have a 2014 Fiat 500L with about 47k on it. It is a six speed manual trekking. I have recently been having random issues with power loss. When driving after a period of time my cruise control will turn off and it is like I have no assistance from the turbo. I have changed the plugs and upgraded my coil packs to the Alfa Romeo packs. It worked fine for a week and now I am having the issue again.

    Anyone else having this issue. I have seen some people report this problem but apparently no fix from Fiat as there is no check engine light.

    Any help is very much appreciated
    Hi zstamp19,
    We understand why this may be concerning. Please let us know via private message if you decide to have your dealer look into this. We would like to have this documented and have a case escalated in your behalf so a Case Specialist can work with your dealer to help find a potential solution.
    Lydia
    Fiat Social Care Specialist

  4. #4
    AWD enthusiast Lifetime Member 5port's Avatar
    Join Date
    May 2012
    Location
    LI, NY
    Posts
    541
    Thanks
    367
    Thanked 235 Times in 181 Posts
    Quote Originally Posted by zstamp19 View Post
    Sorry posted this already but in the wrong spot.
    Hey guys new here I searched around but didnt see a similar post. I have a 2014 Fiat 500L with about 47k on it. It is a six speed manual trekking. I have recently been having random issues with power loss. When driving after a period of time my cruise control will turn off and it is like I have no assistance from the turbo. I have changed the plugs and upgraded my coil packs to the Alfa Romeo packs. It worked fine for a week and now I am having the issue again.

    Anyone else having this issue. I have seen some people report this problem but apparently no fix from Fiat as there is no check engine light.

    Any help is very much appreciated
    Same engine as the Abarth...if you have this harness give it a visual for cracks which will cause a vacuum leak and may cause the symptoms you are having. Its worth an inspection:

    https://www.youtube.com/watch?v=pcoUG2DuZ84
    2016 Fiat 500X Easy/nero cinema, go pedal, LED headlights and reverse, Osram amber DRL, carbon fiber shift gate, ST T9 wheels, PIAA wipers, '17 motor mounts, K&N

  5. The Following User Says Thank You to 5port For This Useful Post:

    DeSoulo (06-17-2019)

  6. #5
    Junior Member
    Join Date
    Apr 2018
    Location
    Los Angeles
    Posts
    26
    Thanks
    1
    Thanked 5 Times in 5 Posts
    Hey Zstamp, I would recommend getting a cheap OBD reader and scanning for codes. My '14 L will throw the 'low boost' code internally, meaning it will show up if I use the OBD scanner, but it will not display the CEL on the dash. Happens more in the hotter months for me, but clearing the code brings back full boost until it decides to go into limp mode again.

Similar Threads

  1. Check Engine Light & Check Engine Message BUT no code stored
    By fast_dave in forum Fiat 500 General Discussion
    Replies: 3
    Last Post: 04-25-2018, 12:36 AM
  2. Fiat 500L TSB 18-033-13- Check Engine Light - DTC P113D Sensor 1/1 Slow Response
    By Fiat500USA in forum Service Bulletins and Recalls
    Replies: 0
    Last Post: 08-29-2013, 12:03 PM
  3. ETC light flashing, loss of power
    By mspace in forum Fiat 500 Issues and concerns
    Replies: 6
    Last Post: 10-02-2012, 12:48 AM
  4. Engine sluggish and check engine light on after 1400 miles
    By Fiat411 in forum Fiat 500 ABARTH Issues and Concerns
    Replies: 48
    Last Post: 05-10-2012, 05:24 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •