500 Madness
 
Results 1 to 4 of 4

Thread: ABS RBS and ESC lights all came on

  1. #1
    Member cdeforrest's Avatar
    Join Date
    May 2012
    Location
    SF Bay Area
    Posts
    41
    Thanks
    6
    Thanked 2 Times in 2 Posts

    ABS RBS and ESC lights all came on

    Cruising along at 35 in cruise control, I tapped the brakes to slow for a turn & all the above lights came on, after a slight stutter. I've reset the 12V system a couple times and drove around the parking lot, but the lights remain on.
    I don't so much care about ABS or ESC right now (the car's going back shortly) but I sure hope the regen system (RBS, right?) is working. That would certainly cramp my range somewhat.

    Other folks have reported that the error goes away after a few drive cycles, but I'm wondering if there's anything else I could check. The gassers have reported failed speed sensors and/or brake switches, but I know our cars are a little extra special when it comes to glitches. That I won't be missing..

    Thanks,
    Chris

  2. #2
    Senior Member
    Join Date
    Feb 2016
    Location
    Northern Virginia
    Posts
    344
    Thanks
    1
    Thanked 143 Times in 93 Posts
    I recommend removing the battery and battery tray, then disconnect and clean the ground connections between the battery and 'frame'. There are four connections: Negative cable between the frame and the battery, strap between where the negative cable connects and the transmission, and the small wire that may be painted-over, which provides the ground to the dash instruments. Don't just tighten the connections. Remove, clean with a wire brush, Scotchbrite, ect., until both the frame stud, frame and cable connections are clean and shiny. After reattaching, coat the connections with some grease to reduce salt and battery acid from corroding the connections.

  3. #3
    Member
    Join Date
    Jun 2017
    Posts
    46
    Thanks
    0
    Thanked 6 Times in 6 Posts
    I invoked these three lights by ummm.... attempting to flatten the tread on some tires I was about to go get changed. It went away on its own by that evening. The car seemed to operate without issue the whole time.

  4. #4
    Member cdeforrest's Avatar
    Join Date
    May 2012
    Location
    SF Bay Area
    Posts
    41
    Thanks
    6
    Thanked 2 Times in 2 Posts
    Update: After driving a half-mile, the ABS light went out. By the next morning (and 35 miles later) all the other lights had gone out as well. Again, everything seemed to be completely functional, just with a lightshow on the dash.

Similar Threads

  1. Will LED's work on our head-lights/tail-lights?
    By Iamdecay in forum Fiat 500e
    Replies: 20
    Last Post: 09-05-2017, 02:38 PM
  2. WTT: Black 500T lights for abarth lights plus cash
    By Abarth236 in forum Parts For Sale
    Replies: 0
    Last Post: 03-29-2017, 10:18 AM
  3. Nero Abarth with Rosso Lights & Rosso Abarth with Bianco Lights
    By NGEN in forum NGEN Customs & Performance
    Replies: 2
    Last Post: 06-10-2013, 03:59 PM
  4. Fog lights!
    By msjulie33 in forum Fiat 500 General Discussion
    Replies: 1
    Last Post: 08-02-2012, 08:56 PM
  5. Fog Lights?
    By Tuschay425 in forum Questions about the Fiat 500
    Replies: 10
    Last Post: 03-31-2011, 09:07 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •