500 Madness
 
Page 1 of 5 1 2 3 ... LastLast
Results 1 to 10 of 43

Thread: 500L Dead Battery

  1. #1
    Junior Member
    Join Date
    Mar 2014
    Location
    North Carolina
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts

    500L Dead Battery

    Hi everyone. Just joined the forum. Not sure if there is a dedicated 500L forum so posting here. Purchased 500L in July 2013. Vehicle has 2600 miles on it. Battery has died twice. First time vehicle sat for about three weeks and all electronics were dead. Couldn't even open doors with remote. Absolutely no response from car. Took car to Fiat service and they found nothing wrong and just charged battery. Second time vehicle sat for only five days. Electronics came on and remote opens doors, but just a click-click-click when attempt to start. Anyone else having this problem? Thanks for your help.

  2. #2
    Senior Member Jester49's Avatar
    Join Date
    Jun 2013
    Location
    Lakewood, Ca.
    Posts
    204
    Thanks
    3
    Thanked 67 Times in 51 Posts
    Quote Originally Posted by gtleo106 View Post
    Hi everyone. Just joined the forum. Not sure if there is a dedicated 500L forum so posting here. Purchased 500L in July 2013. Vehicle has 2600 miles on it. Battery has died twice. First time vehicle sat for about three weeks and all electronics were dead. Couldn't even open doors with remote. Absolutely no response from car. Took car to Fiat service and they found nothing wrong and just charged battery. Second time vehicle sat for only five days. Electronics came on and remote opens doors, but just a click-click-click when attempt to start. Anyone else having this problem? Thanks for your help.

    There was some else on this form that had a similar issue and I think it turned out to be the battery was at fault but that said five days without running the car will almost discharge a good battery, the electronics in the car are always drawing some current. See video!

    https://www.youtube.com/watch?v=B__DqK90IIc



    The mechanics at studio can also check to see what percentage of life is left in the battery. Remember the car sat at studio lot for awhile without being driven too, not good for a battery..
    Last edited by Tweak; 03-02-2014 at 07:53 PM. Reason: Embedded video.

  3. The Following 2 Users Say Thank You to Jester49 For This Useful Post:

    JWD (02-08-2015), nickle (04-12-2014)

  4. #3
    Super Moderator Tweak's Avatar
    Join Date
    Nov 2012
    Location
    NC
    Posts
    11,509
    Thanks
    0
    Thanked 2,416 Times in 1,977 Posts
    Welcome to the forum.

    I have moved this to the Issues and Concerns area of the forum for the 500L.

    I recall someone stating something in relation to not having locked their doors and a battery issue but sadly I do not recall any specifics beyond someone replying they'll be sure to always lock their doors going forward. This may have no relevance to your problem.

  5. #4
    Junior Member
    Join Date
    Mar 2014
    Location
    North Carolina
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Thanks for getting my issue to the right forum. I ALWAYS lock my doors so can't imagine that is the problem.

  6. #5
    Super Moderator Tweak's Avatar
    Join Date
    Nov 2012
    Location
    NC
    Posts
    11,509
    Thanks
    0
    Thanked 2,416 Times in 1,977 Posts
    Quote Originally Posted by gtleo106 View Post
    Thanks for getting my issue to the right forum. I ALWAYS lock my doors so can't imagine that is the problem.
    Happy to help, as for the lock portion I figured it was a long shot. Glad to see more NC people on the forum.

  7. #6
    Senior Member
    Join Date
    Mar 2012
    Location
    Madison, WI
    Posts
    138
    Thanks
    33
    Thanked 22 Times in 17 Posts
    Went to drive my L last night and I've experienced this too. The battery is dead as a doornail. Trying to decide how to treat this since I think it was also the weak-sauce battery that kept the car from starting for about 4 days this past winter.

  8. #7
    Member
    Join Date
    Nov 2013
    Posts
    39
    Thanks
    2
    Thanked 10 Times in 6 Posts
    My car sat for a week while I was out of town. When I came back it was dead. The dealer tells me this is "Normal" There is so much parasitic draw in the L that if you
    don't run it for a week it will go dead. I don't think that's acceptable, but I can't seem to get them to see it.

  9. #8
    Junior Member
    Join Date
    Nov 2013
    Posts
    17
    Thanks
    0
    Thanked 1 Time in 1 Post
    First off we are in Sacramento. The Trekking has been sitting for 6 days and I went out to see if it had any battery issues. It started right up with no problem. Of course it has been in 80-90's here.

  10. #9
    Junior Member
    Join Date
    Aug 2014
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Same problem. Brand new car. First time car sat for 4 weeks. Roadside Assistance jump started it, but when I drove it over 30 transmission would not go into gear. Service ran it through all tests and could find nothing. Recharged battery. A few days later, with no time lag between starts, it was dead again. This time service put in a new Fiat battery. Ran great for 7 months. Left "locked" in the garage for 3 weeks. (I mention "locked" because someone in the forum suggested leaving it sit "unlocked" could drain the battery.) Was not able to unlock door with remote, but did with key. Battery dead. Fix this time was to replace Fiat installed battery with Mopar battery. Also suggested if I leave it for several days unattended in the future, to disconnect negative battery cable. However, this can put the battery into sleep mode, so when reconnecting for use, put key in ignition and turn on. Pump foot rapidly on gas pedal for a few seconds, and while continuing to pump the pedal, crank the key until vehicle starts. Do not turn off...let it run awhile and drive around for 10-20 minutes to be sure it is running properly.

    Hope the Mopar battery works better and the disconnecting works next time I am out of town. Can't put up with this forever. Otherwise love the car.
    Last edited by Onthego; 08-01-2014 at 05:47 PM. Reason: added info.

  11. #10
    Super Moderator Tweak's Avatar
    Join Date
    Nov 2012
    Location
    NC
    Posts
    11,509
    Thanks
    0
    Thanked 2,416 Times in 1,977 Posts
    Sounding more and more like a trickle charge/battery tender solution is needed for L owners.

Page 1 of 5 1 2 3 ... LastLast

Similar Threads

  1. dead battery woes
    By Gundy in forum Fiat 500L Issues and Concerns
    Replies: 15
    Last Post: 02-24-2014, 08:26 AM
  2. Got my trekking and It's already dead :(
    By dichiee in forum Fiat 500L
    Replies: 46
    Last Post: 09-26-2013, 09:54 AM
  3. DIY Footrest/Dead Pedal
    By macfish in forum Fiat 500 DIY
    Replies: 20
    Last Post: 05-27-2013, 10:53 PM
  4. lightweight battery -- mount design and battery sourcing
    By mkawa in forum Fiat 500 Abarth Exterior and Interior Mods
    Replies: 27
    Last Post: 05-06-2013, 04:51 PM
  5. Dead Audio?
    By rhky in forum Suggestions
    Replies: 1
    Last Post: 07-27-2011, 11:54 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •