PDA

View Full Version : So, anybody else's transmission leaking? How about coolant reservoir leaks?



MAZ
05-01-2013, 03:13 PM
Anyone hear of defective rear main seals or defective trans seals? How about coolant leaks?
Car has 8,000 miles and 7 months.

During an oil change I popped the hood and noticed that the coolant reservoir was way low on fluid and that the hose was crusted up with dried coolant residue.
No biggie, just a leaky hose. It happens.

Next, I get under the car and the transmission is coated with either trans fluid or motor oil and is dripping.

Car is headed to Fullerton Fiat tomorrow.

Not a great start...


I'm trying to find any posts about leaking transmissions or rear seal experiences..

Willow1285
05-01-2013, 03:19 PM
Anyone hear of defective rear main seals or defective trans seals? How about coolant leaks?
Car has 8,000 miles and 7 months.

During an oil change I popped the hood and noticed that the coolant reservoir was way low on fluid and that the hose was crusted up with dried coolant residue.
No biggie, just a leaky hose. It happens.

Next, I get under the car and the transmission is coated with either trans fluid or motor oil and is dripping.

Car is headed to Fullerton Fiat tomorrow.

Not a great start...


I'm trying to find any posts about leaking transmissions or rear seal experiences..

not sure about the other stuff but to my knowledge a lot of people have the coolant reservoir leak including myself. I mentioned it to my studio when i went in for a routine maintenance and they told me that many cars actually had a recall on the entire reservoir but my VIN wasnt listed as one of the recalls. They also couldnt fix it because there wasnt a certified FIAT technician in the studio that day (so annoying). But i easily fixed the problem with a worm clamp from Home Depot. Hasnt leaked since.

Plainsman
05-01-2013, 03:38 PM
Maz,

I had the same coolant leak and did the same as willow. No leaks since changing the hose clamps on the top of the coolant bottle and I also changed the bottom connection. Had the same coolant bottle leaks on my wifes 500c so I changed out those clamps too. Neither car was covered under the recall.

Fortunately, no leaks underneath either car. ie engine rear main seal or transmission seal.

trevc
05-01-2013, 03:47 PM
I had a small transmission leak. I tightened the bolts on the top cover, topped it back up (that Mopar transmission oil is expensive!) and so far it looks good.
Small job not worth the time to book it in for service for me. If it reoccurs I will.

Hopefully your leaks can be easily fixed. If its the rear main seal they have to pull the engine and trans unfortunately.

Vaejovis carolinanus aka lowconabarth
05-01-2013, 05:30 PM
I also had a coolant leak, make sure if you replace that you use Fiat Oat coolant as specified.

MAZ
05-01-2013, 06:06 PM
I also had a coolant leak, make sure if you replace that you use Fiat Oat coolant as specified.
yup always!

stealthy1ss
05-01-2013, 07:54 PM
Do you have any pictures of these areas?

Giuseppe
05-02-2013, 10:07 PM
My trans is leaking at the fifth gear cover IIRC. My RMS is dry.

MAZ
05-03-2013, 08:26 AM
Update:
The Studio fixed the coolant leak and confirmed the transmission leak. Not sure if it is the 5th gear area seal.
We'll see how they handle this trans leak issue....

sfhpawel
05-03-2013, 02:09 PM
Please let us know! I dont have a leak... but the gasket is moist and leaves fresh residue on my finger... kinda sucks.

Making an appointment to the studio asap.

Need to get my abs/esc sensor checked out
Oil changed
ask about the gasket

ugh... thought this would be a worry free 4 years :/

MAZ
05-03-2013, 03:42 PM
I dont have a leak... but the gasket is moist and leaves fresh residue on my finger
That's a leak.

MAZ
05-06-2013, 11:47 AM
Update:
Just picked up the car and in fact it was the fifth gear cover that was leaking/defective.
Hopefully resolved and done with!
Props to Fullerton Fiat for letting me pimp one of their 500 loaners for a week, I was happy to give it back, lol.

sfhpawel
05-06-2013, 01:47 PM
Update:
Just picked up the car and in fact it was the fifth gear cover that was leaking/defective.
Hopefully resolved and done with!
Props to Fullerton Fiat for letting me pimp one of their 500 loaners for a week, I was happy to give it back, lol.

Kinda need your advice... I called up the studio last week, made an appointment for Wednesday. But I am reconsidering because the studio only has 3 loner cars... and I need a car for work. So my other option is to try a different studio(kinda wanted to go where i bought the car) or let them put me on a waiting list(lady at the studio said like a 2 week wait) I'm kinda PO'ed ... that they wont offer me an alternative rental car!!!!

The leak isnt that urgent so im sure it can wait like a few more weeks... but my abs and esc sensors are f'ed up... kinda dangerous to drive like that...

what should I do?

Willow1285
05-06-2013, 01:59 PM
Kinda need your advice... I called up the studio last week, made an appointment for Wednesday. But I am reconsidering because the studio only has 3 loner cars... and I need a car for work. So my other option is to try a different studio(kinda wanted to go where i bought the car) or let them put me on a waiting list(lady at the studio said like a 2 week wait) I'm kinda PO'ed ... that they wont offer me an alternative rental car!!!!

The leak isnt that urgent so im sure it can wait like a few more weeks... but my abs and esc sensors are f'ed up... kinda dangerous to drive like that...

what should I do?

i made my studio pay for a rental car... totally different reason, but you can try and see what they say

trevc
05-06-2013, 02:21 PM
Glad to hear they got you taken care of.
Sounds like whoever was sealing these transmissions was not as generous with the sealant as the person bolting in the battery trays was with the loctite :lemo:


Update:
Just picked up the car and in fact it was the fifth gear cover that was leaking/defective.
Hopefully resolved and done with!
Props to Fullerton Fiat for letting me pimp one of their 500 loaners for a week, I was happy to give it back, lol.

sfhpawel
05-06-2013, 02:27 PM
i made my studio pay for a rental car... totally different reason, but you can try and see what they say

I may call a different studio... this lady said Chrysler does not cover Enterprise bills, or outside rental cars... its strange because when I bought the car, I was promised a rental if the car went in for repair...

Willow1285
05-06-2013, 02:29 PM
I may call a different studio... this lady said Chrysler does not cover Enterprise bills, or outside rental cars... its strange because when I bought the car, I was promised a rental if the car went in for repair...

not sure if it was Chrysler that paid or the Studio itself, all i know is it wasnt me!

FiatCACares
05-07-2013, 03:29 PM
Kinda need your advice... I called up the studio last week, made an appointment for Wednesday. But I am reconsidering because the studio only has 3 loner cars... and I need a car for work. So my other option is to try a different studio(kinda wanted to go where i bought the car) or let them put me on a waiting list(lady at the studio said like a 2 week wait) I'm kinda PO'ed ... that they wont offer me an alternative rental car!!!!

The leak isnt that urgent so im sure it can wait like a few more weeks... but my abs and esc sensors are f'ed up... kinda dangerous to drive like that...

what should I do?



Sfhpawel,

You might want to consider asking to speak with the Service Manager directly to see if any assistance can be provided. Do you have a Service contract on the vehicle. If you have any questions regarding your warranty, please PM me and I'd be happy to review it with you or you can contact my US counterpart, Jonathan (FiatCares). You can also contact the Customer Care department at the numbers provided.

Canada: 1-800-465-2001
US: 1-800-992-1997

Giuseppe
05-07-2013, 07:52 PM
I may call a different studio... this lady said Chrysler does not cover Enterprise bills, or outside rental cars... its strange because when I bought the car, I was promised a rental if the car went in for repair...

Load of crap. Whenever I go in for warranty service, they send me to enterprise for a rental.

RustyPaint
06-06-2013, 10:30 PM
Just came back from my first oil change. They did an inspection on the car and reported that my transmission is leaking. They put dye in the in the tranny and told me to comeback in 2 weeks so they can see where it is coming from.

MAZ
06-07-2013, 08:44 AM
Just came back from my first oil change. They did an inspection on the car and reported that my transmission is leaking. They put dye in the in the tranny and told me to comeback in 2 weeks so they can see where it is coming from.
Mine was leaking from the 5th gear cover. Luckily, that is the easiest to fix.
Good luck with that, don't forget about it & get it fixed!

CarlosOne
06-23-2013, 09:56 PM
I know owners are getting mad at me for saying it but, get rid of it before your warranty runs out. These cars are having way to many issues. It seems that the one's that are bad, are really bad. (Not all, I know)

keefer-c
06-23-2013, 10:17 PM
Hrm, I think I am going to get under my car tomorrow to inspect the transmission housing...

MAZ
06-24-2013, 08:43 AM
Hrm, I think I am going to get under my car tomorrow to inspect the transmission housing...
Just turn your driver side wheel and look in, you should be able to see the trans case

keefer-c
06-24-2013, 12:24 PM
Just turn your driver side wheel and look in, you should be able to see the trans case

I just got out of the garage... I jacked it up and got under it, and mine is bone dry. I found no leaks around the transmission housing or otherwise (not even a hint of fluid spots anywhere along the seams, etc). I also checked a few other areas for other issues that are sometimes mentioned here, and found nothing (Thank God).

And man, I think I was in the garage for a total of 15-20 minutes and I must've lost about a liter of sweat...

Lesca
12-27-2014, 05:09 PM
Does anybody have transmission problems with fiat 500 pop? Mine starting as soon I bought it when slow down from second to first gear ( auto) it does it with a Big Bang / jerk or I could be at the light waiting to change and the trany still on second gear then a Big Bang going to first. I took it to the dealer Hearn chambers ( seller) at least 10 times but it didn't happen all the time until it did happen with the head foreman but they refused to fix it because Chrysler did not approve is the way I drive and the computer has to learn how I drive. Actually we computer and me have to have an agreement on how we are going to drive the vehicle? I never heard such answer . Every time they plug the car on the computer does not show any errors but as soon start driving it does happen. I call a lemon law lawyer from PA after a few letters with Chrysler they inspected and same results the car is running as it was built so the lawyer drop the case and I trade the car to the same dealer losing 2/3 of the price that I paid for I feel but for the new buyer because the car was going right to an auction .do not buy fiat I though they were good cars but it did not happen this time. Good luck

gundam2000
12-29-2014, 10:38 AM
had the 5th gear seal problem. dealer fixed under warranty, no problems since.

James Turner
12-29-2014, 10:58 PM
My 14' with 12k on it is moist around the seal...

What's the repair procedure???

shagghie
12-30-2014, 12:05 AM
My 14' with 12k on it is moist around the seal...

What's the repair procedure???

bump!

DuckDodgers
12-30-2014, 01:24 AM
Quick note to those that replaced the clamps on the coolant reservoir. In my case, the tech brought the removed reservoir out to show me what happened. It seems a number of the reserviors had defective nipples/connectors that were deforming under the hose clamps and pressure. Simply putting a better clamp on it might just pinch off the flow completely, so make sure and inspect your reservior nipples if you've done this repair yourself or are considering it.

gundam2000
12-30-2014, 04:00 PM
bump!

receipt says cover was removed the seal was cleaned and cover put back on, fluid was refilled.
im guessing incorrect torque spec from the factory.

wachuko
01-06-2015, 11:37 PM
No issues here... and I do not treat her gently... fun fun fun... car has performed flawlessly.