PDA

View Full Version : Check Engine Light = Misfire



Gharbeson
01-15-2013, 05:39 PM
Trouble in paradise. Check Engine light (blinking) plus text message "Check Engine" off to Fiat dealer. My dealer has ONE Fiat mechanic. 2nd day in shop he tried clearing message but then detecting misfire in 2 cylinders. The car started and sounded fine when the light appeared, no strange engine sounds or stalling??? This car has the MM Power Pedal on for approx 3 months with no issues. Does this sound familiar to anyone?

Current Fiat Deal (Dodge, Jeep, Chrysler, etc) does not seem to be very responsive to the needs of the Fiat owner and with no other nearby dealers I may decide to put the car up for sale although I have thoroughly enjoyed it.

dgreenberg
01-15-2013, 06:26 PM
I have the TMC box and had some similar issues this morning. I was in sport mode accelerating and was getting some misfiring while in 1st gear WOT. 1 mile later ran through 1st 2nd 3rd and 4th WOT onto the freeway with no issues.

Jjm4life
01-15-2013, 06:29 PM
Had it pop up a few times. Have my own code reader so no need to visit the dealer. Car is fine, i think our sensors are crazy sensitive

EliRider
01-15-2013, 06:53 PM
Highly recommend using a obdii reader to get the specific codes. Otherwise you may head for undesirable territory especially if you modify your car. Actually I would be very interested in your MM street/track cat back exhaust system and what you think.

You can typically go to your favorite auto supply store and they may let you borrow one. Here is a link regarding obdii options for your smartphone. Several of us are using these tools.

http://www.fiat500usaforum.com/showthread.php?6182-OBDII-monitor-recommendations

Gharbeson
01-15-2013, 08:37 PM
I think you are right on. I'll see what the say tomorrow. Thanks

Gharbeson
01-15-2013, 08:40 PM
Thanks. I was driving to work and turned around and went straight to the dealer (with their single Fiat mechanic!). I have a OBD reader and would have gone that route if I had been at home. The engine never felt or sounded strange so I am hoping for a case of a sensor problem.

Gharbeson
01-15-2013, 08:43 PM
I was going to put the exhaust system on this week but now... It is beautifully constructed - quite a Christmas gift. I also got the 500Madness CAI which is sitting in a box waiting for install. I bought this car (which I love - normally) from my wife with some cash I was getting ready to plunk down as a deposit for the new Shaguar Type F. We'll see. I will get this baby running right and try the cat back exhaust. I would make a deal on it that couldn't be refused haha. Thanks again

VTEC Mini
01-16-2013, 10:07 AM
With more and more reports coming in about these boxes it sounds like they are more trouble than they are worth. I was thinking about getting one but now I don't think so.

Guest
01-16-2013, 11:44 AM
With more and more reports coming in about these boxes it sounds like they are more trouble than they are worth. I was thinking about getting one but now I don't think so.

I think youll find with the hundreds sold theres less than 5% with issues. I was in the first ever batch of 13 MMs that was sold by Madness and now 23k later I have never had any issues at all. All being equal Id certainly buy it again, but now if I had to go stock id almost certainly sell the car!

VTEC Mini
01-16-2013, 01:43 PM
I think youll find with the hundreds sold theres less than 5% with issues. I was in the first ever batch of 13 MMs that was sold by Madness and now 23k later I have never had any issues at all. All being equal Id certainly buy it again, but now if I had to go stock id almost certainly sell the car!

Do you have the power pedal or what ever its called too? I am trying to figure what is the cause before spending money. It seems the rash of these problems occurred after the factory recall flash update.

EliRider
01-16-2013, 01:53 PM
I think youll find with the hundreds sold theres less than 5% with issues. I was in the first ever batch of 13 MMs that was sold by Madness and now 23k later I have never had any issues at all. All being equal Id certainly buy it again, but now if I had to go stock id almost certainly sell the car!

I second this. No hesitation at all about using the MM modules and other throttle boosters what so ever.
Most of my issue has been around replacing the down-pipe but most of them have settled and nothing to do with the boost modules.

It's great the level of sharing we have had over the several months on our forum in using such modules- so it's all great data for me and hopefully to others that can decide if they want to go down that path. I would definitely buy again.

Guest
01-16-2013, 01:56 PM
Do you have the power pedal or what ever its called too? I am trying to figure what is the cause before spending money. It seems the rash of these problems occurred after the factory recall flash update.

I do have both. Ive not had the PCM reflash and so have also not reprogrammed my MM box. I believe there was a small faulty batch plus a lot of the issues reported here sounded like incomplete/incorrect installs.

I dont believe the throttle pedals and boost controllers interact at all, but there have been occasional CELs when using a throttle box on cruise control.

BigDaddySRT
01-16-2013, 02:26 PM
Trouble in paradise. Check Engine light (blinking) plus text message "Check Engine" off to Fiat dealer....

If your MIL (Malfunction Indicator Light)/ CEL (Check Engine Light) is "Blinking" and an Audible Warning Chime is heard:

"If the MIL flashes when the engine is running, serious conditions may exist that could lead to
immediate loss of power or severe catalytic converter damage.We recommend you do not
operate the vehicle. Have the vehicle serviced immediately."

grayabarth12
01-16-2013, 10:02 PM
ok so there is less than 5% of boxes sold that have this problem....well thats great,unless your the one in that 5%. $900 is alot to spend on something that may or may not develop this malfunction, my question is the ones that had issues are they being replaced....madness? or mm. is there any kind of warranty on th mm box? i dont really want to wait for a replacement for 5 weeks. just thought id through that out there,was curious to see how madness was handling it,if they did have any complaints from anyone. ive had no problems with any thing i ordered from them,and customer service has been great,thats why i will continue to deal with them....thanks in advance

Pinecone
01-17-2013, 11:26 AM
5% doesn't sound like much.

But 1 out of 20 sounds a lot worse.

But both say the same thing mathematically. :)

Guest
01-17-2013, 11:35 AM
5% doesn't sound like much.

But 1 out of 20 sounds a lot worse.

But both say the same thing mathematically. :)

5% was my guess. Madness says its less than 1%

Gharbeson
01-17-2013, 01:18 PM
My semi-competant Fiat Service has spent 2 days looking at this problem. They contacted the home office and as of this morning are leaning towards a glitch in a sensor. They cannot re-create a miss fire situation. I will probably get the car back today. I did not mention my MM Powerpedal nor did the service department seem to notice it. I installed the MM PP after the PCM "upgrade" and have run it for 3 monthsw with no issues until his CEL incident. Thanks to all for the great input! Cheers, George

Gharbeson
01-18-2013, 06:04 PM
4 days at the dealer. They HAVE recreated an actual misfire. Now looking at mechanical vs electric cause.I was hoping for a random sensor spasm. I don't see how a mis fire could be in any way connected to the MM Powerpedal. I have the MM cat back system and 500Madness CAI to instal when I get her back and then make the decision on the MM ECM vs TCM ECM vs the 500 Madness piggyback boost.

Gharbeson
01-23-2013, 04:29 PM
Remains at the dealer! Today after discussions with Chrysler, the tech is going to be looking at injectors. I sorely wish I had taken off the yet to be noticed MM PP. I am in high anxiety. CEL remains on. Something to think about before taking a Abarth in with a mod installed. I went straight from the highway to the dealer. Unable to use OBD reader or remove MM PP.

Guest
01-23-2013, 06:13 PM
Remains at the dealer! Today after discussions with Chrysler, the tech is going to be looking at injectors. I sorely wish I had taken off the yet to be noticed MM PP. I am in high anxiety. CEL remains on. Something to think about before taking a Abarth in with a mod installed. I went straight from the highway to the dealer. Unable to use OBD reader or remove MM PP.

Two possible scenarios.... One you get a an understanding dealer who wont tell Fiat and let this one slide. Two, sadly what Id expect, they wont cover the problem and void the powertrain warranty!

Id bet it just wasnt installed perfectly and is a loose connection. They wont be happy to spend so long diagnosing this only to find the aftermarket item! Maybe their staff are here and already know!

Thomas
01-23-2013, 06:41 PM
They haven't found the underlying cause of the problem yet, right? I can't see how the PP could cause a misfire.

Guest
01-23-2013, 07:06 PM
You could go down there and quickly remove it! Tell them you need something out of it, do it late in the day as they wont be workin on the car, 1min in and out! Could be worse, be harder to shift a boost controller!

Im certain its not the PP but some places will use ANYTHING to get out of warranty work! It happened once on mine about 20k ago, Id tested the cruise control and after 15min use the lights flashed. I cleared the code with my reader and it never came back - i guess the PP messes with the cruise control. The code was a throttle position error which makes sense.

Gharbeson
01-31-2013, 08:57 PM
3 weeks in the shop. Now waiting for Fiat to ship a new ECM. Strange. No word on MM PP invovement.

Gharbeson
02-16-2013, 10:20 PM
Got fiat back from dealer after 5 weeks. Difficulties with programing new ECM. MM PP in place 3 months prior. The MMPP was in place while at Fiat service but not discovered. Service mgr told me to be wary of bring in warranty cars with electronic mods. Most likely the particular service issue would not be covered (I assume this would be some type of electronics problem). Running great now and I will be installing the 500 Madness CAI. I feel like I dodged a bullet, just a heads up. BTW just had my '99 Ferrari 355F1 Spider delivered. Top doesn't work but runs great. It's a Ferrari, what could go wrong. Haha. I really missed my little Abarth so happy to have her back.