PDA

View Full Version : Abarth heated seats



Dwaynek
04-23-2012, 09:40 AM
Anyone get the heated seats as an option in the Abarth?

toddr124
04-23-2012, 10:25 AM
I have been told that heated seats are not a factory option. Also the original mopar heated seat dealer installed option is no longer available. I hope there will be a new option before winter.

I like heated seats.

BillE
04-23-2012, 11:36 AM
........I like heated seats.

So does my wife. She calls them bun warmers ;)

CLXXV
04-23-2012, 12:26 PM
My Studio is supposed to install 2-stage seat heaters when my car arrives in a few days. I don't think these are the elusive Mopar heaters. They said they have installed quite a few of them.

pchop
04-23-2012, 01:49 PM
Butt Warmer is almost a must have option in the NE.

Thunderbolt
04-23-2012, 01:52 PM
Lol at bun warmers!

I have an appointment this Friday to have mine installed. It's a Sport auto, not an Abarth, but at least the option is still available.

pchop
04-23-2012, 07:10 PM
Found this on the web:

http://www.heatedseatkits.com/heatedseatkits/index.html

Seems for around $150-$300 you can get yourself a nice heated seat. Mopar also sees a kit for around $300.

Thunderbolt
04-28-2012, 06:02 AM
Got my "bun warmers" installed today! They are 2-stage. There are a new pair of switches mounted in the plastic that covers the parking brake lever pivot. It was quite warm today so I didn't try them out. The dealer had the car for the entire day.

Btw, my switches and switch emblems look almost exactly like the little round rocker switch in the link that pchop posted. I just can't remember if the LED indicator is on the left or the right. I'll have to check tomorrow.

Thunderbolt
04-29-2012, 04:34 AM
They are not quite the same switch but are very close. Same green/red LED for the low/high setting, but the LED is on the other side of the graphic. They work great! Well, at least the driver's side does. I did switch on the passenger side as well just to test it, but the seat base never warmed up. The seat back worked fine. I could swear that the driver's seat base warmed up and I know the driver's seat back warmed up. I'll have to test it when I'm not sitting in the seat. If the seat bases ARE supposed to warm up, my passenger seat isn't working properly.

dogbolter
04-29-2012, 07:44 PM
Could someone who has had the seats installed post a photo of the location of the switches.

Freedomland
04-29-2012, 08:33 PM
My Dealer has put them into a fiat (they have a guy come in to install it) I've seen the switches on either side of the round transmission lever housing one angled toward the driver and the other angled toward the passenger. however.. it's like $600 installed.

another option I've looked into is Wet Okole heated seat covers... a pair are about $270

Thunderbolt
04-29-2012, 09:52 PM
Could someone who has had the seats installed post a photo of the location of the switches.

http://quads.ca/forum_images/fiat/heated_seat_switches.jpg

So I just checked; my driver's seat base does warm up. I'll call the svc dept tomorrow.

FiaTED
04-30-2012, 01:17 PM
Got my "bun warmers" installed today! They are 2-stage. There are a new pair of switches mounted in the plastic that covers the parking brake lever pivot. It was quite warm today so I didn't try them out. The dealer had the car for the entire day.

Btw, my switches and switch emblems look almost exactly like the little round rocker switch in the link that pchop posted. I just can't remember if the LED indicator is on the left or the right. I'll have to check tomorrow.

Thunderbolt:

Did your Dealer install Factory seat heaters or aftermarket ones?

EliRider
04-30-2012, 02:14 PM
http://quads.ca/forum_images/fiat/heated_seat_switches.jpg

So I just checked; my driver's seat base does warm up. I'll call the svc dept tomorrow.

Does anybody have experience how well this will work with the red leather seats. Curious for the possibility of discoloration. I'm leaning towards not adding but curious.

Thunderbolt
04-30-2012, 04:57 PM
Thunderbolt:

Did your Dealer install Factory seat heaters or aftermarket ones?
Sorry, I don't know. I will ask when I return my car to have the passenger seat heater fixed.

Was nice having a heated seat during my commute today; the weather was cool and raining, and I had a sore lower back as well.

Thunderbolt
05-01-2012, 03:50 PM
The seat warmers are aftermarket and were installed by a contracted company (called "Automotive Styling Centre" or "ASC" in Vancouver). The reason the passenger seat base does not warm up is because there is an airbag sensor there that will not work if the heating pad is installed. So they do not install the seat-base pad for the 500, just the seat-back pad. Apparently that was news to the service dept.

minibrings
05-28-2013, 07:12 PM
I had after market heated seats installed (same switches as above). Odd they don't seem to work if the headlights are off.. only when on
AND only high heat works.. can 't feel anything with low heat. I have to take it back obviously.... same issue with passenger side...

Are they only supposed to work with headlights on? None of my cars that have them worked this way

2300cc
05-29-2013, 09:23 AM
I have the factory heated seats in My Abarth and am very happy with them. I do wish they had 2 or 3 stages, but they automatically circulate from very hot to just warm when they are turned on. Definitely a winner in the winter time!

wilbmeister
05-31-2013, 11:02 PM
I have the factory heated seats in My Abarth and am very happy with them. I do wish they had 2 or 3 stages, but they automatically circulate from very hot to just warm when they are turned on. Definitely a winner in the winter time!

+1 Love the factory heated seats. They were wonderful when the weather was cold.

White Abarth
06-01-2013, 08:53 AM
Are they only supposed to work with headlights on? None of my cars that have them worked this way

Sounds like your installer may have tapped power from somewhere he shouldn't have.

My aftermarket heaters work on both settings whether the lights are on or off (but the car itself has to be on.) I installed the kits myself, have had them in for eight months now and was running the driver's seat pretty much non-stop on high for four of those months. No discoloration or issues with my red leather seats. The only problem I had involved tugging one of the power wires out of its crimped connector under the driver's seat when I jammed the seat all the forward to pull the jack out. A simple reconnect of the wire and slight reroute of the cable to give it a little more slack and all is back to normal.