PDA

View Full Version : Retrofit updated European LED tail lights



Wimbledon
06-22-2018, 01:45 AM
Some US Abarth owners have fitted the updated Euro LED rear lights. Apparently it's plug-and-play if you use a harness manufactured by SpeedMotive. Has anyone upgraded the lights on their 500e?

Install video on a US Abarth:


https://www.youtube.com/watch?v=v5w25FNQxkA&t=14s

David Kasprzyk
06-25-2018, 08:56 PM
I'm just finishing up on installing all led lights on my 500E. Headlights were basically plug and play. I did have to cut cooling holes in the round plastic dust covers. Front turn signals were weird. I had to order 2 different brands of supposedly "canbus ready" led amber turn signal bulbs. First set wouldn't work and second set was indeed plug and play. Rear signals had to have load resistors on each bulb. Reverse lights only needed one load resistor and both lamps operate. Stop/Tail light lamps were very screwy!!!! The Tail light section of the bulb is plug and play with no load resistor needed but the brake light section did require a load resistor on each bulb in order to work. Go figure! Also the Front parking light/ DRL lights have not been changed yet. I'm having trouble locating a true led replacement for the W21/5W Dual filament bulb. Do NOT use the sub most suppliers recommend. The 7443. It only has one "filament" so to speak and does not work correctly. Also there is a difference in the base of the rear turn signal bulb if you get an 1156 led and a true PY21W led. The locking tabs on the PY21W are NOT 180 degrees apart from each other like the 1156 are. To see what I mean look at your PY21W bulb. You'll see what I'm talking about.

Hope that helps and doesn't completely confuse you!!!!

Dave

mintteargas
07-27-2018, 02:27 PM
I was watching that video on Youtube yesterday. They look very nice. I'm interested in them as well. If you get them before I do please update this thread.

texanbrit
07-27-2018, 03:41 PM
I have the setup from Speedmotive. It's super easy to do install and looks great.

scrudge
05-04-2019, 09:53 AM
Which wires did you connect the resistor to for the brake lights?


I'm just finishing up on installing all led lights on my 500E. Headlights were basically plug and play. I did have to cut cooling holes in the round plastic dust covers. Front turn signals were weird. I had to order 2 different brands of supposedly "canbus ready" led amber turn signal bulbs. First set wouldn't work and second set was indeed plug and play. Rear signals had to have load resistors on each bulb. Reverse lights only needed one load resistor and both lamps operate. Stop/Tail light lamps were very screwy!!!! The Tail light section of the bulb is plug and play with no load resistor needed but the brake light section did require a load resistor on each bulb in order to work. Go figure! Also the Front parking light/ DRL lights have not been changed yet. I'm having trouble locating a true led replacement for the W21/5W Dual filament bulb. Do NOT use the sub most suppliers recommend. The 7443. It only has one "filament" so to speak and does not work correctly. Also there is a difference in the base of the rear turn signal bulb if you get an 1156 led and a true PY21W led. The locking tabs on the PY21W are NOT 180 degrees apart from each other like the 1156 are. To see what I mean look at your PY21W bulb. You'll see what I'm talking about.

Hope that helps and doesn't completely confuse you!!!!

Dave

Dillinger63
05-05-2019, 08:38 PM
Step 6. Wash Car. :)