View Full Version : 2017 Abarth Clock...

09-18-2017, 11:56 AM
How do you set the darn thing? I go to the settings menu on the UConnect infotaninment piece. The clock settings are grayed out. I have tried both with the car running and just with the key at the accessory setting. Should I pull the battery cables and reconnect them? Is there some other setting that unlocks the clock settings?

09-18-2017, 12:18 PM
You should just push the menu button on the right side of the dash and go up or down to get to the clock if it's like my 2015. As you scroll you just push the menu button again to initiate the clock and then go up and down to achieve the settings you want. If that doesn't work I would look in the owners manual.

09-18-2017, 12:31 PM
2017's are different. You have to set the clock through the UConnect screen. The manual only says to do what I have done except it makes no mention of what to do if the options are grayed out.

11-06-2017, 09:52 PM
Why didn't anyone answer Iammie200's question?! Does nobody know the answer?

I too am unable to set the clock on my 2017 Fiat 500 Pop. The menu option for setting the time and date is inactive; it cannot be selected on the touch screen.

The solution (from another Fiat 500 forum): Keep the engine running to see all UConnect menu options active and accessible. The owner's manual neglects to specify that important instruction.

11-08-2017, 05:11 PM
go into Sync Time/Clock, turn it off, to back and set the time

11-08-2017, 08:20 PM
go into Sync Time/Clock, turn it off, to back and set the time

This is the answer. I have found that my clock doesn't keep good time unless it is synched (which means synched to my phone, BTW.) The odd thing is that when I bought the car the sales person paired my phone and synched it, but the time read out military style. My phone wasn't set to military style. In any event, I unsynched it, set the time, then resynched it and everything works correctly now. Accurate time and shown in the 12 hour format.