View Full Version : SD card and USB not working

12-27-2014, 02:11 PM
I recently (Monday December 23, 2014) purchased a 500L Trekker. It's been driven twice, once about 5 miles on Christmas Day, and now I'm on the second drive, a 500 mile trip through rural Indiana. If you've driven through there, you'll understand why I wanted to use the SD card for music.

I got an SD card ready last night (64GB, I'll go more into that later, don't jump to conclusions...), formatted it to FAT32 (the exfat it came with didn't appear to work), and tested it out. It worked great in the garage. We got out on the road this morning, and the SDcard option in the media hub screen was greyed out. I tried ejecting the card, putting it back in, turning off the radio unit, all to no avail. Assuming that the card was not working properly, I decided that since I had a lightning cable with me, and an iPhone, and all of the music I wanted was on the iPhone, I'd just use that. Silly me.

The USB option in the media hub screen was also greyed out. I tried the Bluetooth streaming option, and it didn't work either - not greyed out, but it would not let me either see or choose music. By then, the SD card option was no longer greyed out, but it still would not admit there were any files there.

I then got out another SD card that was smaller and slower, since I found something that said only SD card 32GB and smaller, and class 2-8 would work. Class 10 and faster are not recommended. From Chrysler on the uconnect: "Anything higher than a "Class 8" has a transfer rate that is too fast for our systems to recognize." That seems a little odd, but when in Rome... While this is not a Chrysler vehicle, I still thought it was worth following, so I used an 8GB class 4 PNY SDHC that happens to be specifically listed among the Chrysler compatible cards. Same result. Oh, and the files I'm using are all MP3. (For the safety conscious readers, I was riding in the passenger seat while SWMBO was driving. Less arguments when she drives...)

After browsing for a while on this forum and other places on the Internet, I called Fiat. The very nice person on the other end, after doing some research (3 different holds at about 4 minutes each) told me it was either a bad SD card or the uconnect 6.5 was not compatible with the new iPhone software, and suggested I download the newest version of uconnect software, 13.49.0. I looked at the uconnect settings, and that is the version already installed. I thanked her and told her I'd contact my dealer. This is an abbreviated version of what I did, since it took the entire 4 hours from home to Lebanon, IN.

We then stopped for some food (Steak n Shake in Lebanon, IN - delicious. I had the Frisco melt...), and when we got back in the car, all of a sudden the USB connection and the SD card both worked. I rejoiced, thinking all was well. I didn't test the Bluetooth.

Of course, since I am posting, all was not well. We got gas (28.5 MPG on the first tank, not bad), and after starting it up again, it was back to its old tricks.

I called my sales guy (since its a Saturday, service is closed, natch.). He said he'd call his Fiat rep. When he got back to me, he said neither of them had ever heard of this. I've seen several posts on this forum that appear to be similar. Any ideas on what's going on?

I'm going to call early Monday to book a service appointment. Any ideas what I can tell them to look for, or anyone who's gotten this fixed have anything to say?


12-27-2014, 04:22 PM
Hey Melchloe,

What is a SWMBO?

Also, I've noticed odd behaviour with the uConnect and whenever I turned the car off and then back on whatever was wrong would clear up. By chance did all the time you were having these problems the car continue to be driven? That is was the ignition ever switched off during your problem with the S/D card and uConnect?

12-27-2014, 08:23 PM
Hey Melchloe,

What is a SWMBO?

Hmm, I'll take a stab at it and guess it's 'She Who Must Be Obeyed'.

12-27-2014, 10:22 PM
I thought that was WIFE

12-27-2014, 10:29 PM
I thought that was WIFE

Synonyms. :D

12-28-2014, 11:23 AM
DDT: It went on and off several times, and the problematic behavior persisted except for one time. The previous night, the car has been sitting for 24 hours with no activity, and when I tested it, I did not start the car, but just turned the key until power came on to radio. It worked then. The next day, were moving for about an hour when i tried the card on the road and got no results - the first attempt with the iphone was during this cycle too. We drove for about 3 more hours, then pulled over for lunch. We both wanted to power cycle this time, and when we did so, no joy. Took at 1/2 hour break, then it worked. We drove 2 minutes to gas station, shut it off, and then it didn't work when we started back up. Since the problem manifested, it's been power cycled 7 times, and worked only once. I thought at first that the length of time it's off might make it more likely to work the next time, but it was off for about 10 hours last night and did not work when I tried it again today.

SWMBO (She Who Must Be Obeyed): Islander, DDT, and Tweak are all correct. It's from a Haggard novel, where "She" was the mystical leader of an island society, then from Rumpole of the Bailey where it was used as a snarky term, and these days it's a term for wife, usually online...

12-28-2014, 12:35 PM

You may just need to get the radio replaced. I had a strange problem with uConnect, where sometimes Sirius/XM would not work. They replaced the unit. Perhaps that's what you need.

12-28-2014, 01:17 PM
Hi everybody,I have the same issues,my USB port work and not work and no patterns it works whenever it feels like it also my Sirius reload but I have to say Bluetooth works all the times.They make me laugh at Fiat when they say they never saw that issue,it s pretty odd that we all complain about all the same things and post are growing and no solutions.A few examples,the double clutch issues the clutch noise for manuals,throttle response,uconnect.

12-29-2014, 12:58 PM
I have also had the same issue since I bought my Trekker in May. My dealership said maybe the UConnect system needed to be updated. The nav system also occasionally reboots, which is really frustrating.