PDA

View Full Version : HELP! Only 18 lbs of boost with a Magneti Marelli ECU



Carcraz8
12-25-2014, 07:24 PM
Here my story I jumped in my little abarth to head over to moms for Christmas Brunch . I look forward to a fast ride on Christmas day do to the lack of highway patrol :clap::clap: Im hitting it on the freeway and notice im am not able to hit 21 lbs of boost . God knows how long ive looked down to see the
exact amount ive been getting but norm is 20 with a hit and miss on 21 lbs. I then down shift to third and notice at 5000 rpm my boost drops from 18 to 8 as the speed increases. Can anyone PLEASE HELP?

Abarth619
12-25-2014, 09:23 PM
When did you install the MM ECU? Do you have the stock boost gauge? If you have the stock boost gauge it will not give you a accurate reading with any piggyback.

Carcraz8
12-25-2014, 11:16 PM
I have an ATM boost gauge

Tweak
12-25-2014, 11:18 PM
Did you still feel the power increase?

Carcraz8
12-25-2014, 11:39 PM
I do except in 3rd it does not seam as violent feels weak!

Tweak
12-26-2014, 12:19 AM
I do except in 3rd it does not seam as violent feels weak!

Perhaps a temp change has at least slightly changed things? Maybe try resetting the ECU? I never did own a MM so I am not 100% certain of all the ins and outs that might factor into running it. Each ECU mod is varied enough to have to be learnt with time. I'd try resetting and see if that improves things since it is such an easy troubleshooting step to take.

chrisnack
12-26-2014, 12:31 AM
Yeah i'm seeing 20lbs in 5th and 18lbs in 4th since i installed the MM... quite disappointed with it... others report 22-24lbs of boost. I have the ATM gauge as well. I've reset the ECU a few times. I've tried beating on it after reset and i've driven nice for 80+ miles and then checked boost levels.

I'm getting rid of it and going to go with something else, appears to much better options out there now.

Carcraz8
12-26-2014, 08:48 AM
Alright I'll unplug it this morning and plug it back in . I'm driving to Nebraska today we will see how it does and I'll report back a few hours in to the trip.

Abarth619
12-26-2014, 09:38 AM
I know when I first installed my RRM Ulitimate it took a while before the car would make 22 pds of boost. I also have other mods as well that would help it get to that level of boost. Give it a couple weeks and let the car learn the piggyback a little.

shadowshaggy
12-26-2014, 05:44 PM
Also, you're in Wisconson. Temp affects how much boost it'll make. Reset the ecu and go from there.

opiateESP
12-26-2014, 06:04 PM
Doing the boost leak fix can help with the loss of boost at the top end.

Carcraz8
12-27-2014, 12:49 AM
I'm in Nebraska and I got 26 mpg the first tank 23.7 the second and 22 for the last! There is something wrong with this thing for sure!!! The check engine light after the last tank . Oh and I ve had this ecu installed for the last year! Almost for got I unpluged the ecu after each fill up ;(

Carcraz8
12-27-2014, 05:00 PM
I will do the boost leak fix this week !

Hildevar
01-30-2015, 08:24 AM
I will do the boost leak fix this week !

Sorry, what is this boost leak fix?

Tweak
01-30-2015, 12:49 PM
Sorry, what is this boost leak fix?

http://www.fiat500usaforum.com/showthread.php?10140-How-To-Evaporative-Re-Route-and-Boost-Leak-Fix&highlight=boost+leak

Purgatory
02-02-2015, 01:53 AM
If you don't already have one, try the GFB Diverter Valve. Made a huge difference in holding the extra boost from my Uni-Chip Stage II and RRM HP Downpipe with Cat, really helps hold the boost when letting off gas to shift. Was worth every cent of the 135 bucks I paid for it. To me, a must item for any serious engine mod plan. Just a suggestion.

500turbah
08-08-2015, 08:33 PM
ive been having a huge boost leak problem as well, i was at 20psi tops holding around 18psi with the road race tune. after adding the injen intake, i lost psi down to 15 psi. i recommend getting a check valve. i just ordered the HPSI check valve its said to give no cel and help contain boost at high levels while allowing the valve to open and close as it should under low rpms. let me know if you solve your boost leak issue!