PDA

View Full Version : Repeated cel from boost leak fix



cy-clone33
06-19-2014, 07:28 PM
Has anyone figured out how to stop this; I reset my ecu every 150 miles for a EVAP CODE ,, I called the vendor and have tried their solution ( WD40 ) sprayed into the valve but it hasn't stopped after 3 months

What would happen if you bypass the valve ( remove it ) and connect the line directly to the CAI fitting ?

Guest
06-19-2014, 09:14 PM
Has anyone figured out how to stop this; I reset my ecu every 150 miles for a EVAP CODE ,, I called the vendor and have tried their solution ( WD40 ) sprayed into the valve but it hasn't stopped after 3 months

What would happen if you bypass the valve ( remove it ) and connect the line directly to the CAI fitting ?

I hope you don't have the garbage Tork kit... Get the HPSI kit and you'll never see the CEL again. Tough luck, hope it goes away

AudiGuy
06-20-2014, 09:39 AM
I bought the Boomba and have yet to throw a code.

modular
06-20-2014, 06:19 PM
I bought the Boomba and have yet to throw a code.

http://i105.photobucket.com/albums/m203/scottozanne/misc1/pointup_zps035ca230.jpg

This.

Jester49
06-20-2014, 07:55 PM
Has anyone figured out how to stop this; I reset my ecu every 150 miles for a EVAP CODE ,, I called the vendor and have tried their solution ( WD40 ) sprayed into the valve but it hasn't stopped after 3 months

What would happen if you bypass the valve ( remove it ) and connect the line directly to the CAI fitting ?

What's the code #????

cy-clone33
06-20-2014, 09:53 PM
pl1cea I believe

dylansi
06-20-2014, 10:19 PM
We need to know which of the boost leak "kits" you are using

cy-clone33
06-20-2014, 10:26 PM
We need to know which of the boost leak "kits" you are using


I don't want to say anything bad.. My understanding after reading is that several owners have the same issue and Im just looking for a fix,, Ill pM you the info you are looking for

Chops
06-21-2014, 10:10 AM
You don't have to say anything... It's in your signature.

"TORK TUNE AND BOOST FIX"... Apparently, it hasn't fixed anything and gave you more issues.

Jester49
06-21-2014, 11:01 AM
pl1cea I believe

That's not a valid OBDII code....

cy-clone33
06-21-2014, 12:07 PM
That's not a valid OBDII code....

because I dont remember it exactly , I had it read at autozone its an evap code , I called the seller of the boost leak and they were familiar with the code

Yes the TORK boost leak is in my signature, I kinda forgot that,, BUT Im not bashing John, just wanted to see if anyone figured out how to get rid of the issue

Abarth Five O
06-21-2014, 02:14 PM
P1CEA

If your build was pre 2/13, the TSB re-flash to eliminate that code might help in getting rid of that code w/ the Tork BLK and other fixes.

cy-clone33
06-21-2014, 02:37 PM
P1CEA

If your build was pre 2/13, the TSB re-flash to eliminate that code might help in getting rid of that code w/ the Tork BLK and other fixes.

OK you sound way smarter than me,, what is TSB reflash?

ivmill
06-21-2014, 04:00 PM
OK you sound way smarter than me,, what is TSB reflash?

It's a Technical Service Bulletin. Sort of like a recall light, haha. I believe the one he's referring to is this: http://www.automd.com/tsb/bulletin_b361016/

Fiat500USA
06-21-2014, 04:19 PM
Just a reminder, we have a Fiat tech bulletins (TSB) forum on our site: http://www.fiat500usaforum.com/forumdisplay.php?72-Service-Bulletins-and-Recalls

musicsurf
06-21-2014, 05:02 PM
I don't know if they reflash everything with that particular update, but there's a chance the tune will be overwritten and you'll have to send your Ecu back to John.

cy-clone33
06-21-2014, 05:14 PM
I don't know if they reflash everything with that particular update, but there's a chance the tune will be overwritten and you'll have to send your Ecu back to John.


that would be the straw that broke the camels back LOL

Tweak
06-21-2014, 07:45 PM
I don't know if they reflash everything with that particular update, but there's a chance the tune will be overwritten and you'll have to send your Ecu back to John.

Excellent point Mike!


that would be the straw that broke the camels back LOL

Sounds like until you know for sure that CEL isn't so bad anymore huh...haha. :D

cy-clone33
06-21-2014, 08:05 PM
its just sucks, it was advertised as no cels, cost to much for what it is and U get the darn cels

Tweak
06-21-2014, 08:25 PM
its just sucks, it was advertised as no cels, cost to much for what it is and U get the darn cels

Understandable and I'd feel the same if it were happening to me buddy.

Abarth Five O
06-22-2014, 02:53 AM
Perhaps Tork could tune out the cel?

Jester49
06-22-2014, 12:43 PM
I don't know if they reflash everything with that particular update, but there's a chance the tune will be overwritten and you'll have to send your Ecu back to John.

The code for my CEL was a P0456 and they did erase the ECU and re-program ,not overwrite. I saw an immediate benefit when I drove away, feels like it's in SPORT mode and SPORT mode is awesome !! My mileage did go down from 38 to 36mpg though.

cy-clone33
06-22-2014, 03:14 PM
jester you had the tork tune when you did this ?

Jester49
06-22-2014, 06:43 PM
jester you had the tork tune when you did this ?

No Tune, was part of TSB and just happen to throw code when I pulled in to the service dept. for a oil change.
I learned early in my life not modify my DD because it will never go as planed. If I have the money I buy a car that I can toy with and mod. on the weekends and for what ever reason it doesn't run, not a problem I still have my DD.

Abarth Five O
06-28-2014, 02:15 PM
Ron, Did you get other suggestions from Tork? I'm still living w/ P1CEA w/ the Tork BLK and am planning to get the TSB re-flash to hopefully get rid of that code.

cy-clone33
06-28-2014, 02:37 PM
yes I did get a response, they suggested changing the valve, My impression was they were going to take care of it, Ive been busy and will have more info shortly

Just sent James a PM requesting the replacement valve, I don't know if its a different valve or just a stock one

Abarth Five O
06-28-2014, 02:48 PM
The check valve is a cheap part. Hopefully it gets rid of the cel. Good to have the part # in case I need to change that out too. Thanks

cy-clone33
06-28-2014, 02:49 PM
James has been helpful, Im just getting frustrated because this has gone on for months

ophidia31
06-28-2014, 05:31 PM
Do you want the chance of it popping up once, code clear and then it wont show until you hard reset the ecu? Boomba valve or the evap reroute which is a little more than putting a check valve inline. (cheap)

Do you want it to popup never? HPSI fix. (expensive)

Only options in my eyes.

cy-clone33
06-28-2014, 05:53 PM
I agree, but I have $60 invested in the TORK that's a large amount for no more that the kit is I would rather they stand up and get it to work

DIVSAbarth500
06-28-2014, 07:35 PM
I have to ask this question: Why did you buy the Tork "fix" when the three other solutions were all out before it? There was a huge amount of debate about the HPSI, Boomba and Ryephile mods and while there was disagreement about which was the best solution long term, everyone was in agreement that the Tork mod was crap, in more ways than one, when they introduced it.

Eat the $60 as a sunk cost and do one of the other three. There is plenty of info on the forum to help you decide.

NGEN
06-28-2014, 08:32 PM
We have the HPSI version and it has worked great. Yes it is more expensive but the quality is there and no CELs. We do not have any experience with the other ones so we can't comment on them. We just know the HPSI works great.

trevc
06-30-2014, 09:23 AM
Just do the Ryephile mod. Following musicsurf's illustrated instructions it is easy and I don't know of anyone that has had issues with it if you use the parts specified. This is what I ended up doing after trying various check valves and I am glad I did it.

NOTHINGCUTEABOUTMYCAR
07-02-2014, 08:16 PM
I installed the TORK TUNE boost leak repair about 500 miles ago... and I have no CEL. Have you inspected the check valve is in correctly? I am not affiliated with Tork.

cy-clone33
07-02-2014, 08:22 PM
yes I have,, and I didn't get my first cel till about where you are

Im not here trying to bust there backside.. I only want it resolved , like you I paid my $60 and just want it to work..Again the TUNE I bought it FANTASTIC .. this is the only issue Im having

NOTHINGCUTEABOUTMYCAR
07-02-2014, 08:51 PM
I, ironically enough spoke to TORK today about the CEL. They said it's hard to know the exact reason why your car has a CEL but others do not. Makes me a Lil nervous but I'm optimistic.

Abarth Five O
07-02-2014, 09:37 PM
yes I have,, and I didn't get my first cel till about where you are

Im not here trying to bust there backside.. I only want it resolved , like you I paid my $60 and just want it to work..Again the TUNE I bought it FANTASTIC .. this is the only issue Im having

Ron, Did you receive the replacement check valve yet? I am wondering if it is an oem or aftermarket part. Hopefully it will do the trick.

MattLima
07-08-2014, 08:07 PM
Has there been a resolution? My car just threw a CEL today as well after installing the boost leak fix. Had it for 3 days.

Abarth Five O
07-08-2014, 08:35 PM
Has there been a resolution? My car just threw a CEL today as well after installing the boost leak fix. Had it for 3 days.

http://www.fiat500usaforum.com/showthread.php?16642-500-miles-CEL-for-boost-leak-fix&p=692853#post692853