PDA

View Full Version : Does your 500L has the same problem as mine....



FERNIEW
03-11-2014, 10:51 PM
1- MIL(engine check) light on
2- Engine running rough, mostly at idle
3- Rear passenger seat folds but does not tumble
4- Uconnect radio, have to press buttom twice for the selection you want
5- Key FOB has low range, you have to be next to the car to lock/unlock doors

Car is in service for the second time, MIL came on the next day car was picked up from service.....only 4000 miles on it.

Always contact Fiat customer service for any service done, that way you get a case number which they will follow up with you and the studio.

500spot
03-12-2014, 12:46 AM
I have an OBDII reader I use to nail down problems like that. If you don't, you should get the car to the studio right away. The rear seats should tumble, again. see your service dept. Uconnect - get the new reflash and your uconnect should be fine. battery in your key fob needs replaceing.

markinmad
03-12-2014, 11:53 AM
There are two levers that release the rear seats. One near the top and one down by the seat belt anchor. If I remember right only one of them releases the tumble catch.

Johnny1814
03-18-2014, 09:52 AM
I have an OBDII reader I use to nail down problems like that. If you don't, you should get the car to the studio right away. The rear seats should tumble, again. see your service dept. Uconnect - get the new reflash and your uconnect should be fine. battery in your key fob needs replaceing.

I checked the Uconnect website and couldn't find an update...Where did you get the new relflash?

guerrafa
03-30-2014, 02:23 PM
I had a similar issue with the MIL , car was about 3 weeks at shop, they had to replace some electronic circuit related to injection.