PDA

View Full Version : 2012 abarth front end noise



racecar001
01-27-2014, 02:08 PM
Hi, 1st post !! Well I have the bump noise in the front end of my car. I have a appointment on Friday to get it checked out. I did jack up the car and noticed the top hats on the struts are loose. I can pick up the wheel and there is play where the mount sandwiches the body. I looked at the bump stops and can't imagine them making noise even if they do slide down the shocks. It looks like I have the revised bumpstops anyway. I will post what they find out.

2012 abarth stock suspension 2500 miles.. sad

ScorpionSkins.com
01-27-2014, 02:46 PM
It's a common issue. There was a TSB released for the jounce bumpers. Did you already bring the vehicle in for their replacement?

What occurs with the factory strut top mounts when they are removed and reinstalled, is that they are very likely to start making noise due to bearing alignment defect.

When I had my bumpers replaced, I had to return to the dealership to later have new strut top mounts installed. I'd recommend that if you're having the jounce bumpers replaced under the TSB, you ask the dealership to install a new set of strut top mounts with the swap out to avoid having to return for front end noise a second time.

There is an aftermarket solution in the works for the strut top mount by All Angles Design. You can read more on their development here:
http://www.fiat500usaforum.com/showthread.php?12701-Upgraded-and-adjustable-strut-mounts

racecar001
01-27-2014, 09:02 PM
Are the bad jounce bumpers longer then their replacement? The bump stops are very short and can't imagine they are making any noise. The top mounts are loose like the rubber is messed up. I am sure when I hit a bump the noise is the strut top slamming on the body.

racecar001
01-27-2014, 09:12 PM
So at 2000 miles my strut tops are garbage?? If so they should have a redesign at the factory not a aftermarket answer. That shouldn't happen in 100000 miles regardless of strut removal. I guess we will find out what they say. I think from pics on the net it looks like I have the updated bumpstops.. or jounce bumpers.

ScorpionSkins.com
01-27-2014, 10:25 PM
So at 2000 miles my strut tops are garbage?? If so they should have a redesign at the factory not a aftermarket answer. That shouldn't happen in 100000 miles regardless of strut removal. I guess we will find out what they say. I think from pics on the net it looks like I have the updated bumpstops.. or jounce bumpers.

No, the strut mounts aren't necessarily garbage, but they are prone to failure when removed and reinstalled. They function as they should if never removed. For more details, this thread thoroughly documents the issue and shows the root of the issue:
http://www.fiat500usaforum.com/showthread.php?12654-Anatomy-of-a-FIAT-500-Strut-mount

Fiat hasn't recognized the problem because there's technically no problem to recognize, unless the top mounts have been removed and reinstalled, at which point you're likely (but not certain) to encounter noise due to their misalignment from their original position.

I'm just giving you a heads up to save you another dealership trip. Your dealership may very well choose not to recognize this, so you'd be obligated to return a second time should you encounter strut mount noise after which point the jounce bumpers have been replaced. It's all warranty work anyhow so don't feel too upset about it.

Speaking of the TSB, here are more details:
http://www.fiat500usaforum.com/showthread.php?9785-Tech-Bulletin-02-002-13-Cold-Weather-Noise-From-Front-End-Over-Bumps

I don't have a photo of the revised jounce bumpers readily available, but they have a tighter inner diameter reducing movement and eliminating the noise issue. The Aftermarket available option is good for those of us on modified suspension setups that would like a more thoroughly reliable design.

Fiat500USA
01-28-2014, 12:24 AM
I did jack up the car and noticed the top hats on the struts are loose. I can pick up the wheel and there is play where the mount sandwiches the body.

Welcome to the forum! When you jack up the car and take weight off of the wheel the strut mount will do that. They are similar to VW mounts and they do the same thing when you jack up the car.

racecar001
01-28-2014, 12:47 PM
Ok well I was wondering that. I had a vw beetle turbo s and had done suspension work to it and they are mounted the same. I have seen where dealers cut the "bad" bumpstops off while waiting for new ones to be shipped out. I plan to lower the car anyway so I may jack it up and cut the bad bumpstops off to see if it fixes the issue. Again I don't understand how a free floating bumpstop can make a noise.

racecar001
01-31-2014, 08:01 PM
Boom... Fixed !!! They replaced bumpstops like everyone said and It is good to go. I still don't get why they would make such a noise but it is fixed.

Tweak
01-31-2014, 09:44 PM
Boom... Fixed !!! They replaced bumpstops like everyone said and It is good to go. I still don't get why they would make such a noise but it is fixed.

Always a good thing when issues get resolved, thanks for reporting back with the good news!

Mini Cord
02-01-2014, 09:55 AM
Keep an ear on them. The problem unfortunately comes back.

In my Yellow 500 sport they were replaced to the upgraded version in June. I took the car again in December and they have replaced them again.

My Abarth is a 2013, started making the noise a few weeks ago.

Seems like the Canadian winters are not helping at all.

ScorpionSkins.com
02-01-2014, 12:32 PM
Keep an ear on them. The problem unfortunately comes back.

In my Yellow 500 sport they were replaced to the upgraded version in June. I took the car again in December and they have replaced them again.

My Abarth is a 2013, started making the noise a few weeks ago.

Seems like the Canadian winters are not helping at all.

You are probably experiencing strut mount noise as opposed to jounce bumper issues at this point. (Just a theory, based on my own replacement experience)