PDA

View Full Version : Add me to 500L Transmission error



blackswan
01-03-2014, 05:13 PM
Over the last few weeks, the shift button would not depress when I attempted to shift to drive from park. Seemed to occur when the cold snap hit us in the Mitten. I would turn off the engine... wait a few minutes.. then turn engine back on and I could shift into drive.

Reported it to service manager at the studio.

A week later the 'trick' worked but as I shifted into drive the dash lit up with several transmission warnings and the check engine was solid yellow. Took it in to the studio and they performed a check and apparently there was some software update.

Then yesterday I could not get into drive.. did the 'trick' again and I got several transmission warnings. Took it in to the studio. Service was able to retrieve service codes (and I cannot remember the exact name). Today the service manager was able to replicate the problem and was having a conference call with Fiat engineers. Transmission assembly is on order (and I believe other parts) according to the service manager.

Meanwhile, I am in a 'baby Fiat' rental, with Fiat footing the bill. Happy with the level of attention and the treatment from Fiat. Definitely NOT happy with this type of problem, especially since I am reading about other similar problems.
FWIW I have a 2014 Trekking.

I will report back when I know more.

bryanintowson
01-03-2014, 05:38 PM
Oh noes! I hope you're enjoying your regular flavor 500 - glad to hear that they're taking good care of you. We all braced ourselves for this to happen when we first bought our 500's back on 2011/12 and for the most part there were few major issues. The ones that did crop up, FIAT/Chrysler took care of us.

I had a failed gauge cluster that required my car to be laid up for almost 2 months waiting for parts. Chrysler took care of me and I wanted for nothing. Since then, it's been 30,000 trouble free miles. *knocks on wood*

Hope you get back up and running quickly!

Stacey Willard
01-03-2014, 06:42 PM
I am having many troubles with my 500L Trekking. The 2nd week I owned it, I couldn't shift into Park or Drive at different times. A piece broke off and they had to order a part. They had my car for a week when it was onlly 2 weeks old. Now I am having intermittent check engine light come on and also intermittent trouble with the shifter lights (PDRN) flashing and making clicking noises. My hatch rattles like crazy when it's warm out. Today my driver side window auto up no longer works. The auto down does, but not auto up. I'm getting really frustrated and may have to start looking at the lemon law.

blackswan
01-07-2014, 09:02 PM
Update 1/7/2014
Service manager called me this afternoon. He has been communicating with Fiat engineering. They are of the belief that this is a software not a hardware issue. They do not currently have an update and do not know when an update will be available. Additionally, they also believe that the transmission 'parts' that have been replaced will not fix this issue...meaning that the problem will come back. The engineers specifically said to NOT replace any parts in my Trekking.
The service manager has been able to replicate the problem several times and recommends that I let the car engine run for 2 minutes before putting it into gear.

I'll be reporting back.

Stacey Willard
01-07-2014, 10:38 PM
What is this, 1975? I'm really supposed to let my 2014 model car sit for 2 minutes before driving it? That's ridiculous in this day and age.

Stacey Willard
01-10-2014, 12:10 PM
Update: Just call word about my car and the check engine light and flashing shifter lights. There was no check engine code stored but there is a tech services bulletin he hoped would solve that issue. There was a code for the transmission for low voltage that will cause the lights to flash. My driver side window auto up stopped working and he said that low voltage was behind that problem too. My battery was really low and the deep cold we had in Ohio made it worse and caused the low voltage problems. So, hopefully now that they have charged the battery my issues will go away.

bryanintowson
01-11-2014, 08:57 PM
glad to hear it! keep us posted on anything else.

superchan7
01-12-2014, 01:52 AM
Glad to hear some progress on your L. Best wishes for a reliable car from now on!