PDA

View Full Version : Random drop in boost.



frank283
09-21-2013, 10:41 PM
I have a 2012 Abarth with around 30k miles and sometimes the car will only generate around 6lbs of boost in sport or normal mode. Not sure if itís because of the heat or what but if I turn the car off and restart it I goes away. Not sure whatís going on. I only run 93 octane.

ewflyer
09-21-2013, 11:31 PM
I've noticed my 2012 Abarth limiting boost as part of the ESC's torque-limiting and stability programming. The highway on-ramp that I regularly use has a couple of pretty hard turns in it (basically an "S" turn). When I take this on-ramp with the ESC on the boost stays low while I'm cornering hard. When I remember to turn the ESC off (press and hold for 5 seconds, until it beeps) the car delivers full boost throughout the on-ramp's curves.

millers500x
09-22-2013, 12:00 AM
My 2013 did this to me about a week ago, I stopped turned the car off then on again and it was fine.

musicsurf
09-22-2013, 12:11 AM
I have a 2012 Abarth with around 30k miles and sometimes the car will only generate around 6lbs of boost in sport or normal mode. Not sure if it’s because of the heat or what but if I turn the car off and restart it I goes away. Not sure what’s going on. I only run 93 octane.

Do you have any modifications done to your car?

charliesheen
09-22-2013, 06:12 AM
2012 Abarth here with 20k miles. Happened to me 3 times so far. It seems like it's an issue that's happened to a lot of Abarths (google "fiat abarth turbo problems"). It happened once when the car was stock, then twice with my CAI and blow off plate. Would love to know if anyone knows what it is.

stealthy1ss
09-22-2013, 12:59 PM
I have a video on my phone of my car doing this. It only happens when it is hot out and I to have an intake.

Abarth Five O
09-22-2013, 11:44 PM
U could have a leak somewhere in your IC piping. If u have Dash Command or Torque app, u could check on pending codes and isolate the source of the problem. Other than that, I would take it in to your LS for diagnostics and warranty service.

stealthy1ss
09-23-2013, 06:52 PM
But it only happens when its hot outside and it is not every time that its hot. Another thing that I noticed is when you let off the gas the discharge is not crisp, it sounds more like its just puking the air out.

Abarth Five O
09-23-2013, 07:40 PM
But it only happens when its hot outside and it is not every time that its hot. Another thing that I noticed is when you let off the gas the discharge is not crisp, it sounds more like its just puking the air out.

This car runs hot, hot, hot, especially in a hot environment. What kind of intake are u running? I have the R/R CAI, engine shield, AC hood vents, and turbo blanket which together helped significantly reduce under hood temps and maintain more consistent boost levels under different temp conditions.

stealthy1ss
09-24-2013, 06:24 PM
I have the R/R intake without the shield. This car does get very hot but why only intermittently. I have race my car with the intake on at Road America for a 25 minute session on a 90* day without any issues.

frank283
09-24-2013, 08:05 PM
But it only happens when its hot outside and it is not every time that its hot. Another thing that I noticed is when you let off the gas the discharge is not crisp, it sounds more like its just puking the air out.

Sounds just like mine. I have a 500madness intake as well.