PDA

View Full Version : Navigation not activated



BlueStreak
09-10-2013, 12:29 AM
Ok I did search for this issue but I found nothing. Lots of people with issues with the SXM though.

I just bought a 500L Lounge with Beats and the "FREE" Premier Package. My salesman told me after everything that the Navigation is not activated but I can have it activated for only $50 but the service department was closed so I couldn't do it til later...I thought it was included but said ok. I left without Navigation activated. I pushed the button and it says something about needing activated and a TSB code. I was just reading my Window Sticker and it says the Premier Package includes Uconnect 6.5" Touch Screen Radio with NAVIGATION System, RearView Back-up Camera, and ParkSense Rear Park Assist. Is it me or does that say I should have Navigation? Why would I pay $50 to activate something that should already be activated?? Someone please help. Thanks

Fiat500USA
09-10-2013, 01:41 AM
Hi, welcome to the forum! Here is the TSB forum (http://www.fiat500usaforum.com/forumdisplay.php?72-Service-Bulletins-and-Recalls)that has something about activating navigation. That might help snd hopefully someone with a 500L will chime in. We also have a Fiat Rep here named Fiat Cares (http://www.fiat500usaforum.com/member.php?1368-FiatCares)in case you need more help.

Luv2byte
09-10-2013, 01:45 AM
The studio has to activate it but why would they charge you, nuts. Try another studio.

n00dle
09-10-2013, 02:54 AM
I bought my 500L on a Saturday afternoon. The dealer couldn't activate the NAV until Monday and I was ok with that. I was told the NAV company that authorizes was closed on the weekends. My sales rep took a photo of the serial numbers the NAVI displayed and told me that I would have my authorization codes on Monday via email. On Monday I received my authorization codes as promised, I punched them in and it instantly activated my NAV unit. I did not pay extra, the NAV is included with the car. Seems like someone's trying to fleece you, I suggest reporting the incident to the General Manager and perhaps even FIAT USA and the BBB.

BlueStreak
09-10-2013, 09:55 PM
Ok so I waited til 10 for my salesman to call me today and nothing so I called Service and she said there is not a charge to activate it. It was nothing more than me having to come back in to have them activate and I was good to go...So I made the 1 1/2 hour hike over to Ft Wayne to have it done. Tabitha the Service Rep was great to work with and took care of me quickly and efficiently. Just upset that I had to go back. I took advantage of it though and made them clean the car because they did a crappy job the night before. It was dark so I didn't notice how bad it was before I left. They did so without hesitation and both the sales manager & sales man were very apologetic and attentive to my concerns.

This is my 5th FIAT purchase and I am not upset by the experience but it was not the best of all of them. I traded in an Extremely Clean (Better than Showroom) 2012 Abarth with 13k. It was a tough decision to trade it but I am over it...I have 3 kids and the 500L is certainly more practical than the Abarth. Besides I didn't like putting miles on it...I would only take it out to Car Shows and that was it.

Robert Nixon
09-10-2013, 10:35 PM
happy ending, YAY!