PDA

View Full Version : Fiat 500 Abarth TSB-18-028-13 MIL P1CEA- Boost Side Evap Purge



Fiat500USA
09-05-2013, 10:50 PM
There is a new Tech Bulletin out for 2013 Abarths with the P1CEA code. This time it is a reflash that fixes the light. Read below:

2013 Fiat 500 Abarth TSB 18-028-13

SUBJECT:
Flash: MIL Illumination P1CEA- Boost Side Evap Purge System Performance

OVERVIEW:
This bulletin involves selectively erasing and reprogramming the Powertrain Control
Module (PCM) with new software.

MODELS:
2013 (FF) Fiat 500/Abarth (Hatchback only)

NOTE: This bulletin applies to vehicles equipped with a 1.4L engine (sales code
EAF) built on or before February 14, 2013 (fiat500usaforum.MDH 0214XX).

SYMPTOM/CONDITION:
A small number of customers may experience a Malfunction Indicator Lamp (MIL)
illumination. Upon further investigation the Technician may find that the following
Diagnostic Trouble Code has been set: P1CEA- Boost Side Evap Purge System Performance

Updating the PCM software will correct the condition listed above.

Corrnaus
09-05-2013, 10:55 PM
wasnt this the code that people were getting with some of the MPx throttle bodies?

Fiat500USA
09-05-2013, 11:15 PM
I think you're right. I know this code was being thrown on 2012 cars. That was because a valve was installed backwards. This is another problem and is listed for 2013 cars.

Robert Nixon
09-08-2013, 05:30 PM
thanks for posting.

I have a 2013 built last year but haven't seen any codes.

Fiat500USA
10-08-2013, 01:41 AM
There has been a revision to Tech Bulletin (TSB) 18-028-13 (now called 18-028-13 REV. A)

The following two codes were added:
**P0456- Evap System Small Leak**

**P0128- Thermostat Rationality**

If you have these codes and your car is under the MDH range, this TSB may take care of your problem. Make sure you consult your dealer, and it is a good idea to print this out and show them in case they don't have the TSB yet. The dealership will still have to diagnose your car and make sure all systems are operating properly.

musicsurf
10-09-2013, 12:12 AM
SWEET! I get to pull out my evap reroute yet again to bring it in for the P0456 code. At least the code will go away.

banzaitoyota
12-23-2013, 10:22 AM
just threw this code on the way to work this morning

EldoradoMike
03-02-2014, 04:59 PM
Plus 1, got the code today on my 500T

EldoradoMike
03-05-2014, 02:19 PM
The studio tech's say it's an over boost condition, "a glitch". My only mod is a K&N filter, and it threw the code at freeway speeds. I'm not happy with that diagnosis as their fix was to reset the code and test drive it.

Ryephile
04-08-2014, 02:43 PM
I got my ECU reflashed at my local dealership today under the premise of TSB-18-028-13 Rev. A. It was quick and painless, in-n-out in about a half hour. They even ran my car through the grind-o-wash. Thank goodness I have a layer of Opti-Coat on the paint, LOL.

No perceived change in drivability so far, other than the car *might* be running about 1 pound more boost. I'll have to do more datalogging to double check that, just going off the turbo boost gauge with that.

We'll see how the expanded P1CEA thresholds turn out.

abarthspd
05-21-2014, 06:17 PM
I got this code a few weeks after installing my new exhaust. Will the studio still fix the issue for me or will they try to blame the exhaust for the code?

Tweak
05-21-2014, 09:33 PM
I got this code a few weeks after installing my new exhaust. Will the studio still fix the issue for me or will they try to blame the exhaust for the code?


Welcome to the forum.

Every dealer can be different in reaction and handling of modifications but this issue is not specifically related to the exhaust, it affects those with stock setups and the dealer (most if not ALL) should handle it without issue.

shagghie
05-22-2014, 01:04 PM
Sanity check for those just joining the community too... P1CEA is also the code everyone gets who has done the original 'free hp mod' or 'check valve' mod. It would come on, usually just once after any ECU rest, and usually while on freeway cursing at steady throttle above 65mph. I noticed once I did the NorcalSS DP mod, that my P1CEA would come on a lot more frequently.

However, after getting my car flashed a few weeks ago, I haven't seen it come on since! (and now I know why, ha!)

Abarth Five O
05-22-2014, 11:58 PM
Dang it, shagghie, now I have to remove my U3 before I take it in for the re-flash. :dread:

shagghie
05-23-2014, 11:05 AM
Dang it, shagghie, now I have to remove my U3 before I take it in for the re-flash. :dread:

Right? Wish u had a good service tech out there like we have here that doesn't ask you to take it out, sheesh!

BigT
06-01-2014, 07:24 AM
yup driving to work this morning CEL came on. Ran torque to scan for pending codes P1CEA guess I'll give the studio a call on Monday and get this TSB taken care of.

DaytonAbarth
07-03-2014, 04:48 PM
I got this coming home on the highway, right after I downshifted to 3rd to get on the highway behind a minivan going 47mph. Thought maybe I overreved or something. Crap, tomorrow's a holiday & I've been off all this week, now I'll probably be stuck taking time off next week for this.

sk8ace
07-08-2014, 07:22 PM
Just tripped this code on my way home from work. Going to reset it and see if it comes back..

ScorpionSkins.com
07-08-2014, 10:22 PM
I've tripped this code twice so far, with a 3500 mile interval in between. The steady highway driving is what triggered it both times. I recently had the PCM reflashed. I'm hoping that's the last time I see it. :)

nilfinite
07-09-2014, 01:23 AM
Tripped this code today as well. My car was built after February 14, 2013 so I shouldn't need to do this update. First time I tripped this code.

DaytonAbarth
07-09-2014, 07:50 AM
I got this coming home on the highway, right after I downshifted to 3rd to get on the highway behind a minivan going 47mph. Thought maybe I overreved or something. Crap, tomorrow's a holiday & I've been off all this week, now I'll probably be stuck taking time off next week for this.

Got into the dealer yesterday morning at 8am, done by 835am. It actually cleared itself the night before, but they said they knew there was a TSB out for it so they reflashed the ECU & I was on my way.

FiatCACares
07-09-2014, 08:47 AM
I've tripped this code twice so far, with a 3500 mile interval in between. The steady highway driving is what triggered it both times. I recently had the PCM reflashed. I'm hoping that's the last time I see it. :)

ScorpionSkins,

The flash performed is designed to address the P1CEA code set. Be sure to notify you Studio if the code returns.

Abnormalradio13
07-18-2014, 07:29 PM
Question. I pulled the p1cea code today cruising on the freeway. I have RRM intake and stage 3 ECM. If I have my ecu flashed, will it damage my ecm

Abarth Five O
07-19-2014, 03:17 AM
Question. I pulled the p1cea code today cruising on the freeway. I have RRM intake and stage 3 ECM. If I have my ecu flashed, will it damage my ecm
Remove your ecm before you get it reflashed.

Rconn14
03-16-2015, 09:57 PM
Hi all - new here. I purchased a 2012 with 35k on it this past week and of course the CEL goes off today with the P1CEA code.

Does the TSB only apply to 2013's or will the reflash also be the remedy for the 2012? Also happened on the highway.

Thanks! Loving the car otherwise.

FiatCares
03-17-2015, 03:41 PM
Hi all - new here. I purchased a 2012 with 35k on it this past week and of course the CEL goes off today with the P1CEA code.

Does the TSB only apply to 2013's or will the reflash also be the remedy for the 2012? Also happened on the highway.

Thanks! Loving the car otherwise.

Hi Rconn14,

There is a service bulletin, TSB 18-018-12, to address the MIL P1CEA on the 2012 Fiat 500 Abarth models. This bulletin applies to vehicles equipped with a 1.4L turbo engine built before April 25, 2012. You will need to take your vehicle to a FIAT studio so that they can inspect the boost vacuum purge harness in your vehicle. Please let me know if I can assist you with making that appointment.

Rconn14
04-27-2015, 06:26 PM
Hi Rconn14,

There is a service bulletin, TSB 18-018-12, to address the MIL P1CEA on the 2012 Fiat 500 Abarth models. This bulletin applies to vehicles equipped with a 1.4L turbo engine built before April 25, 2012. You will need to take your vehicle to a FIAT studio so that they can inspect the boost vacuum purge harness in your vehicle. Please let me know if I can assist you with making that appointment.


So I had it in about 3 weeks ago and they "fixed it". This past week it came on again. :numbness:

My dealership is an hour away and I can't keep making that trek. Is there a permanent fix for this P1CEA issue?

(and the rear struts are bad and need replacing, but are apparently on back order)

FiatCares
04-28-2015, 09:26 AM
So I had it in about 3 weeks ago and they "fixed it". This past week it came on again. :numbness:

My dealership is an hour away and I can't keep making that trek. Is there a permanent fix for this P1CEA issue?

(and the rear struts are bad and need replacing, but are apparently on back order)

Hi Rconn14,
I’m sorry to hear that this issue has arisen again. Could you please PM me with your VIN#, contact information, and the name of the dealership you are working with so that I can assist you further?

Abarth500.
07-22-2015, 01:50 AM
I noticed only the hatchbacks were included, is there different engine programing for the cabrio? Is the cabrio detuned a bit or something?