PDA

View Full Version : Service Airbag Systems warning immediately after dealer performed oil change/inspect.



Daniel Kufner
09-04-2013, 03:34 PM
So my 2013 Fiat Abarth was running fine. No warnings. No compliants. I took it into the dealer for its first oil change and when I went to start it up I heard a loud beep and the HUD reported that I needed to have the Airbag systems serviced soon. Does anyone have any technical knowledge as to what could have happened. The dealership was closing so they could not look at it that day. Dealer can't get me in for a week so now I'm driving around in a car with no airbags. Do you think something got pinched while my car was on the lift? Or caused by a technician when they were doing the inspection and using the diagnostic program? Funny thing is, I looked more closely at the paperwork they provided and right in the documentation under:
B Perform Coutesy Vehicle Inspection
"5660 Airbag Light is ON."

So basically the guy who did my inspection didn't notice that there was, in fact, a problem with my car, and even though the warning was present during the inspection, he did nothing to address or notify me of the issue. Needless to say, I am not confident that Due Diligence was exercised.

trevc
09-04-2013, 04:04 PM
I believe there is a collision sensor mounted close to the rear of the right headlamp. They may have disturbed or disconnected this when getting to the oil filter.
Check that first.
You should disconnect the battery first before attempting diagnosis as you don't want to trigger the airbag deployment accidentally!

JackandSue
09-04-2013, 05:00 PM
I believe there is a collision sensor mounted close to the rear of the right headlamp. They may have disturbed or disconnected this when getting to the oil filter.
Check that first.
You should disconnect the battery first before attempting diagnosis as you don't want to trigger the airbag deployment accidentally!

Same thing happened to me at the dealer. If your not sure how to fix it drop by dealer it only takes a minute.

lammie200
09-04-2013, 09:28 PM
Probably as trevc said. I don't know about Abarths but non-turbo 500's have a collision sensor near the oil filter. It is so tight in that space that someone could easily damage it by removing or installing the filter. I moved the sensor temporarily out of the way to change my filter. I am also going to try to space out the windshield washer filler neck a bit to make more space. The mounting bolts are under the wheel well liner.

Tweak
09-04-2013, 09:44 PM
Seems enough have replied with info/suggestion...I just wanted to welcome you to the forum.

Fiat500USA
09-05-2013, 12:06 AM
Welcome to the Forum! I just want to second the suggestion on removing the battery cable. Here is a safety note from Fiat that may come in handy for anyone working on the car:

Warning: Disable the airbag system before attempting any steering wheel, steering column or instrument panel component diagnosis or service. Disconnect and isolate the negative battery (ground) cable, then wait two minutes for the airbag system capacitor to discharge before performing further diagnosis or service. This is the only sure way to disable the airbag system. Failure to follow these instructions may result in accidental airbag deployment and possible serious or fatal injury.

MAZ
03-24-2014, 04:28 PM
Hello All,
I need to revive this thread.
I have the "Airbag failure" light on, can this be reset without having to the car to the dealership?

trevc
03-24-2014, 04:44 PM
Turn the car off and check the connectors under the front seats to make sure they are not disconnected or loose.
Beyond that you will have to visit the dealer unfortunately.

Hello All,
I need to revive this thread.
I have the "Airbag failure" light on, can this be reset without having to the car to the dealership?

Small&Wicked2013
03-24-2014, 06:19 PM
as suggested earlier in the thread..make sure you dont have a damaged, unplugged or loose sensor wire connector near the oil filter

msjulie33
12-03-2016, 01:50 PM
This place is great, quick search found exactly the fix for my sudden airbag light - the plug at the pass side headlight is so (too) easy to knock free...

rolandblais
09-21-2017, 01:31 PM
Hi. Quick question regarding the sensor near the passenger headlight. Does anyone have a picture or diagram of where it is? I tried looking for it and couldn't find it. I'm having the same issue - airbag light/warning came on after oil change. Nearest good Studio is 165 miles away. :-(

Thanks!

Southernroadrunner
09-21-2017, 03:30 PM
Hi. Quick question regarding the sensor near the passenger headlight. Does anyone have a picture or diagram of where it is? I tried looking for it and couldn't find it. I'm having the same issue - airbag light/warning came on after oil change. Nearest good Studio is 165 miles away. :-(

Thanks!

I can't find a pic right now. But it is just left of the headlight where the hose comes off of the turbo. Where the hose bends it's right there