PDA

View Full Version : Clutch Pedal Sticking?



apmondi
07-28-2013, 01:41 PM
Have had my Fiat 500 Abarth since June 2012.
Any Abarth owners out there have the problem where your clutch pedal slave/master cylinder has failed?
I had this problem back in Feb 2013, got it fixed. Recently they detected a leak in the transmission seal and put
in a whole new trans (July 27th, 2013 to be exact). When I drove the car home, the problem reared its ugly head
once again. I'm not a gear-head, I bought the car because I like it, however these seem to be 3 major issues
in just about a year...

Tweak
07-28-2013, 04:32 PM
Welcome to the forum.

I have read of at least one other with the problems you mention but I do not think it is a widespread issue by any means. Hope you get it resolved quickly and easily with your dealer though!

dylansi
07-28-2013, 04:35 PM
I currently have the leak but have not had any problems with my clutch yet. Hopefully you can get this resolved.

apmondi
07-29-2013, 07:07 PM
Got it fixed today. Apparently when they installed the new trans they didn't "pump" the clutch enough to get all of the air out when the fluids were changed. I gotta say the service manager at Fiat in Maple Shade NJ (Will is his name) is freakin great. My Abarth is all good now tho - clutch pedal is tight and awesome. I love my car but I'm hoping most of the problems sprout up and are resolved during the warranty period.

1970BMW2002
09-23-2013, 08:08 PM
My new Abarth acquired 8/30/2013 experienced clutch sticking when fully depressed for a period of a second or a few seconds. Cause?

Abarth619
09-23-2013, 08:25 PM
My clutch has been okay, but I have noticed that my brake pedal has been a little sticky.

euro951
07-03-2014, 12:12 AM
I currently have the leak but have not had any problems with my clutch yet. Hopefully you can get this resolved.


"The Leak" / sticky brake, clutch pedals/ "New transmission"

what are the BAD problems on the Abarth ??

I almost bought a cabrio yesterday.

where is link to list of these growing issues ?

Dwaynek
07-03-2014, 01:02 AM
mine is a 2012 one of the first in western Canada. 37,000 kilometres and no issues