PDA

View Full Version : computer problems in new car?



hellokelly76
07-18-2013, 09:56 AM
I just purchased my fiat 500l almost 2 weeks ago. I love the car, however, I've already had it into service twice. The radio will just automatically go into aux mode with nothing attached to it and my airbag dummy light sometimes comes on. I was told yesterday that there is a glitch with the computer that is throwing false signals and that fiat engineering is currently working in a fix, but they aren't sure how long that can take. I'm OK with the airbag light, but the radio is really annoying. Anyone else going through this? I understand this is a brand new model and I have had great experiences with my previous 500, just hoping it won't take long to get this problem fixed.

FiatCares
07-19-2013, 03:41 PM
Kelly: Id have both checked out by the local studio, especially the air bag light. PM me with you VIN and I can start a case file with your studio of choice.

Tweak
07-19-2013, 06:56 PM
Welcome to the forum, I hope they quickly resolve your problems. FiatCares is already on the case so that's a good start in getting help. :)

dindob
08-07-2013, 03:04 PM
We bought our 500L three weeks ago, and had the check engine warning light pop up yesterday. We took it to the Studio (Burlingame, CA), and was just told that it's an "O-2" software issue for which a corrective patch is not as yet available (October, possibly)! My vague understanding is that this has to do the software component that dictates the mix of gas & air. In the mean time, they reset the warning light, and advised me that it may pop up again until the software patch becomes available. I assume this will affect the efficiency of the engine and the mileage per gallon (one of the main reasons we bought the car). I hope it does not cause any damage to thhe engine. Of course, to add to my misery, the dealer has a shuttle service to the mass-transit BART (great!), but no return shuttle service to the Studio (not great! did not have this issue with our previous cars in warranty service). I love the form & function of car, but this dampens my enthusiasm about it. Hope the software issue can be resolved sooner than later.

JWD
01-19-2015, 07:52 PM
Hello Kelly, Was your radio problem ever resolved? I just purchased a 500L Lounge with UConnect 6.5 that has the same behavior with both FM Radio and Sirius XM cutting out randomly for various lengths of time with the display going into Aux Mode, prompting for an Aux input device, the same way you describe. I also have no devices connected through Aux, Bluetooth, etc., and the radio cutouts seem entirely random, i.e. not in tunnels, valleys, under overhangs, etc. Was there a fix for this "glitch"?
t.i.a., John